1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

V21 Pre-release sketch issue

Discussion in 'v21 Pre-Release' started by bigseb, Mar 14, 2020.

  1. bigseb

    bigseb Alibre Super User

    While creating a 2D sketch (in part workspace):

    Trying to trim an arc. AD wouldn't do it. Yes, they are all on the same plane, etc, etc. Then after a few attempts I get the 'reference not set to an instance of an object' error message. In sketch mode. After that every time I move the mouse the screen flickers. A lot. As in fit-inducing strobe type flickering. Even when mousing over the background the screen flickers.
     
  2. bigseb

    bigseb Alibre Super User

    This just happened again. While sketching rectangle.
     
  3. Dave Machock

    Dave Machock Member

    I've seen this happen once with the current release, on an arc I was trying to trim. Had the screen flicker also. I restarted the program and everything worked fine. I have not seen it since. I had just decommissioned my desktop unit and put everything on my new laptop, so I figured it was just a freak glitch.
     
  4. 5130wes

    5130wes New Member

    I have also seen this on the current release, but also thought it was my system, or just a glitch, rather than AD. It is becoming a regular ocurrence now thought and sometimes AD has to be restarted and sometimes just the file.
     
  5. simonb65

    simonb65 Alibre Super User

    I've had and reported in another thread issues since HOOPS introduction whereby selecting an edge on a 3D model and applying a feature (i.e. chamfer), does not show on the rendered model, but it shows in the feature tree. Subsequent selection of the 'displayed' edge (which now presumably doesn't exist in the models internal data geometry), results in similar flickering and 'instance of object doesn't exist' error (which when searching for that edge in the model ... doesn't!!). Not sure if it ever got fixed in subsequent minor releases and don't know if it has been addressed in v21. I'm personally convinced that there is a sync issue between what is in the internal stored data geometry structure and what (or when) the data in the 3D graphics pipeline. Perhaps due to render optimisation or missed UI model modified events! Not seen it recently, but then again, I haven't used Alibre for a month or so.
     
  6. JST

    JST Alibre Super User

    With all the crazy stuff I have seen, I do not think I have seen THAT problem.

    Does it seem in any way related to the size/complexity of the model? I ask because several other things that I HAVE seen appear to be more associated with larger models, for reasons that are unknown.
     
  7. 5130wes

    5130wes New Member

    I have seen it on small as well as large files. It seems to be random. It has ocurred when I am just simply drawing a circle or any basic shape and an action can't be completed. Then the error box appears.
     
  8. idslk

    idslk Alibre Super User

    I've triede to edit "oldfox" chess figure (the exploded dxf in part sketch mode! not the part file! ) and suddenly the display started to flicker and a few moments later a requester appeared for a millisecond (to short to see any content) and it disapeared. After this Alibre hung up. Tried it a second time, same behaviour. I'm sorry, but i'm not using the Beta, it happens in 20072.
     
  9. oldfox

    oldfox Alibre Super User

    Of all the folks in this thread and anyone else who has been experiencing this phenomena, how many are using laptops and how many
    are using "towers" or desktops? My thinking is really leaning toward hardware and/or imports.
    Imports as in parts, not computers.
     
    Last edited: Mar 28, 2020
  10. DavidJ

    DavidJ Alibre Super User Staff Member

    A user has reported a reproducible way to trigger the 'flickering' (a fairly specific workflow) - hopefully that'll enable some diagnosis to take place. Of course there might be other triggers, and perhaps some variations on the theme, but it should help if we can find out what is happening. This isn't v21 related.
     
  11. DavidJ

    DavidJ Alibre Super User Staff Member

    A fix has been put in place for the flickering, fixes 2 reported workflows that trigger it - will be available with v21.
     

Share This Page