1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

v2019 - Ambient Occlusion in Illustration Mode

Discussion in 'General Discussion' started by simonb65, Jul 24, 2019.

  1. simonb65

    simonb65 Alibre Super User

    With ambient occlusion on in Illustration mode you seem to get shadows cast by the menu bar and design explorer pane! ...

    upload_2019-7-24_12-24-25.png

    Also, adding ground shadow shows that the Illustrated part is transparent ...

    upload_2019-7-24_12-25-14.png

    and turning on the planes and axis, just causes them to be included in the heavier weight model outline ...

    upload_2019-7-24_12-26-30.png

    and changing the view from Perspective to Orthographic changes the shadows quite a bit (why are the shadows on the perspective view so jaggy and dense?) ...

    upload_2019-7-24_12-28-43.png
     
  2. NateLiqGrav

    NateLiqGrav Alibre Super User

    Same here. Do you also see sketches in illustration mode are also drawn too thick?
     
  3. simonb65

    simonb65 Alibre Super User

    Yes, it seems to treat all items, including sketches, planes, axis, reference lines as part of the model. It really should only use model geometry for this feature!
     
  4. idslk

    idslk Alibre Super User

    slightly different here:

    upload_2019-7-25_12-43-55.png upload_2019-7-25_12-44-31.png upload_2019-7-25_12-46-48.png upload_2019-7-25_12-45-34.png
     
  5. simonb65

    simonb65 Alibre Super User

    You need to go to "Customize performance" and select "Fast" and "thick external edges" ...

    upload_2019-7-25_12-32-52.png

    I suspect you just have "Regular" selected!
     
  6. idslk

    idslk Alibre Super User

    upload_2019-7-25_15-45-49.png
    upload_2019-7-25_15-46-19.png

    wireframe
    upload_2019-7-25_15-47-11.png

    Looks like "thick external edges"
     
  7. Kozure Okami

    Kozure Okami New Member

    Plz don't rain on me. How is the occlusion mode enabled? I got the visual style bar on view tab but is disabled as well as illustration view option on Edge and face display.
    I just upgraded from an old Alibre version and I am navigating new features. Got Alibre design Expert package.

    Thanks in advance
     
  8. I have this same problem in Atom 3D. Kozure Okami, did you get it resolved?

    Pete
     
  9. simonb65

    simonb65 Alibre Super User

    No, Alibre haven't fixed it yet!
     
  10. Max

    Max Administrator Staff Member

    This is probably a limitation of HOOPS. If we were to fix it, we would likely just have to disable ground shadows and reference geometry alltogether when wireframe mode is on. Not the fix you may want, but probably the only one that is possible.
     
  11. simonb65

    simonb65 Alibre Super User

    Hi @Max, if you look at my original post (and @idslk 's post), you could probably do this, as it's what I have to do manually every time after selecting Illustration Mode to get a clean illustration of the part. It makes no sense to leave them on in this mode anyway.

    Don't forget, you would need to restore their state back to what it was prior to Illustration mode if you select another mode ... just so you don't have to go through the reverse manual process of enabling them back on when exiting (if they were enabled before)!

    I'd be very happy with this solution and I'm sure others would be too. It would clean up the UI no end!

    Edit #1 : Ambient Occlusion could be turned off too as it looks overpowering and pretty bad in Illustration Mode!
    Edit #2 : It does on my models, but @idslk 's example above doesn't look too bad.
     
    Last edited: May 18, 2020
  12. Max

    Max Administrator Staff Member

    OK. After v22 ships, v23 will be almost exclusively a "polish" release. Bugfixes, UI fixes, etc. This would be a good candidate for that release.
     

Share This Page