1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tracing images - I can't calibrate [fixed]

Discussion in 'Using Alibre Design' started by Bartek S, Oct 24, 2020.

  1. idslk

    idslk Alibre Super User

    You've said this before and i answered in post #8 - no further comments from my side...
    Regards
    Stefan
     
  2. Bartek S

    Bartek S Member

    Bartek - again why do you want to use calibrate for a second time ?

    this is not the second calibration - it is only a way to show You that the calibrated image is wider after pressing ok (after first calibration)
     
  3. Bartek S

    Bartek S Member

    ok, please take a look on 0:11 sec - this is the moemnt when i push "ok" after finishing calibration




    in the second film it also happened in 11 sec.



    you can clearly see the enlarging of image


    /Bartek
     
  4. DavidJ

    DavidJ Alibre Super User Staff Member

    OK - I don't see that enlarging behaviour when I use Calibrate.

    So the question is what do we have to do to replicate it? - there's something about your system that is triggering the issue. It's very difficult to investigate if we can't replicate the behaviour.

    Try re-setting your Alibre User profile (shortcut on Utilities Tab of Home Window) - a damaged profile can cause a wide variety of UI issues.
     
  5. bigseb

    bigseb Alibre Super User

    Been following this thread since it started but hadn't tried the tracing calibration til now. Works fine for me. Odd one.

    AD V22
     
  6. Bartek S

    Bartek S Member

    it happens on two computers :-(
     
  7. DavidJ

    DavidJ Alibre Super User Staff Member

    Bartek - did you try re-setting user profile as suggested? At least on one computer....

    I am trying to work out what is happening, or to fix it.
     
  8. Bartek S

    Bartek S Member

    did you try re-setting user profile as suggested?

    Of course David , i did
     
  9. DavidJ

    DavidJ Alibre Super User Staff Member

    So I guess it didn't help ?
     
  10. Bartek S

    Bartek S Member

    unfortunately it did not help - I think I have to wait for the service pack or something ... but thank You for the good intentions and the attempt to help
     
  11. Bartek S

    Bartek S Member

    David it still bothers me - please do one test for me because I have installed it on another computer and I have still the same effect. Put this square from attachement - it's 247x247 pixels, size it with calibration tool 10x10mm. After that please draw a square around and measure with a tool whether the drawn square is really a square :) / for me there is a 2mm difference
     

    Attached Files:

  12. simonb65

    simonb65 Alibre Super User

    Both the same for me (if not quite 10mm!) ...

    upload_2020-10-28_23-29-2.png
     
  13. NateLiqGrav

    NateLiqGrav Alibre Super User

    I think you are forgetting something in your test. 10mm / 247 pixels is approximately 0.0405mm error for every pixel you are off when you click. And that's just for drawing the square after calibrating. You could be off by pixels when calibrating too. Here is my best attempt when zooming way in to calibrate and also when drawing the square.
    upload_2020-10-28_22-27-25.png

    I see this all the time when laying a building plan on a Google maps image. For example a single pixel in the map image could be 8" wide (depends on zoom and photo quality for area).

    That said there is definitely an issue with the scale value being truncated when you click in one of the text boxes. Try typing something longer in like 0.222222 in one of the scales then hitting tab until you get back to it. You will see the image preview jump from 0.222222 down to 0.200000
     
  14. DavidJ

    DavidJ Alibre Super User Staff Member

    If I calibrate the square to 10mm by using the line it stays at that (at least to limit of my ability to place the calibration line and my subsequent sketch lines accurately).

    If I type in a scale of say 0.33333333, it seems to be respected even though the scale figure gets rounded to 0.3.

    Nate - thanks for the extra description - I can now get a jump in size if I enter 0.248888 (say) and Tab right round the dialogue back to that box (and then beyond it). The rounded 0.2 in the display gets applied as if it was a newly entered value next time around.

    [EDIT - I guess that isn't too surprising, if you change the value in the scale box, you expect scale to change]

    I still can't replicate the scale jump on hitting OK after using the Line calibration tool - maybe I'm missing some step in users descriptions when I try to follow.
    [EDIT - Are users clicking the OK button in the dialogue when they see this problem, or using a key press? ]
     
    Last edited: Oct 29, 2020
  15. Bartek S

    Bartek S Member

    finally found a real screen recorder :)

     
  16. simonb65

    simonb65 Alibre Super User

    It's not another one of these 'comma' decimal place issues is it?
     
    MKR likes this.
  17. DavidJ

    DavidJ Alibre Super User Staff Member

    I see it, but still can't replicate it. Odd that the jump seems to affect the horizontal direction only.

    Perhaps send your dxdiag information to support - that will allow some checks for possible graphics hardware issues (or rule that out).
    https://support.alibre.com/support/...26984-how-to-provide-dxdiag-and-msinfo32-logs


    Simon - interesting question. I'll try switching regional settings to see if I can get this to break as illustrated.
     
  18. DavidJ

    DavidJ Alibre Super User Staff Member

    Simon - you were right. I changed decimal separator to comma from point and now I see the issue.

    I'll feed that to QA/Development.
     
    simonb65 likes this.
  19. MKR

    MKR Member

  20. DavidJ

    DavidJ Alibre Super User Staff Member

    I believe this was resolved by the Service Pack (build 22051). Are there any residual problems remaining with this function?
     

Share This Page