1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Surface disappears with tangent constraint

Discussion in 'Using Alibre Design' started by slipstick, May 12, 2018.

  1. slipstick

    slipstick Member

    Here's one - if I make the circle of the smaller cylinder tangent to the larger cylinder surface, the surface it is drawn on disappears. The red circle is where I made the tangent constraint.

    upload_2018-5-12_10-14-16.png
     
  2. simonb65

    simonb65 Alibre Super User

    It's easily reproducible, so I would raise a ticket for the dev team to look at ...

    upload_2018-5-12_17-27-52.png

    It only seems to fail under certain conditions ... One set of conditions to make it fail is ...

    To Reproduce : Set Sketch<1> diameter to 100mm, Sketch<2> diameter < 34mm = FAIL, >= 34mm = OK.
     
    Last edited: May 12, 2018
  3. slipstick

    slipstick Member

    How do I do that? I'm new here. :)
     
  4. simonb65

    simonb65 Alibre Super User

    https://support.alibre.com/support/home ... create an account, login and submit a ticket. Add the text to reproduce from the bottom of my post, so they have a repeatable way of reproducing it.

    upload_2018-5-12_17-41-17.png
     
  5. bigseb

    bigseb Alibre Super User

    This problem is still prevalent then is it? Was really hoping it would have been fixed by now...
     
  6. Oldbelt

    Oldbelt Senior Member

    SurfaceAndTangentCon (1).jpg
    Its a Bug, and happens when the minor cylinders axis fall into the plane, a minor distance at some thents of a millimeter as shown here "cure"
    failure.
     
  7. albie0803

    albie0803 Alibre Super User

  8. slipstick

    slipstick Member

    I've submitted a ticket and the rep has passed the issue off to the developers. :)
     
  9. dwc

    dwc Alibre Super User

    I hope it gets looked at soon.
    I see this quite often, but was never able to find out what is causing it.
    Now that I look it does look like it has something to do with tangent constraints.
    Don
     
  10. bigseb

    bigseb Alibre Super User

    I tried this last night. Worked fine. Didn't expect that...
     
  11. bigseb

    bigseb Alibre Super User

    So here's something interesting...

    Modelled this in AD. Added fillets. Worked fine.

    Capture.JPG


    Then I modelled it in Catia. Couldn't do it!

    Capture2.JPG

    Didn't expect Catia to say uncle so easily...
     
  12. slipstick

    slipstick Member


    here's the file I attached to the ticket
     

    Attached Files:

  13. oldfox

    oldfox Senior Member

    I duped this and it worked fine also.

    Seb, Try closing the file and Alibre and then reopening the file without the fillets. Just curious.

    I couldn't help playing with this one. It looked so simple. There seems to be a DEFINITE FIX for this. Don't get me wrong, that's not to say that it shouldn't be happening. It still needs fixing in the code.

    I tried using dimensions, random placement, different sizes for cylinder 2 and Tangent constraint. The only thing that I could reproduce,
    regardless of the method of drawing, was to CHANGE the Render Quality. CHANGING was the key, not the setting of RQ. I could start out
    FINE and change down or start out COARSE and change up and the transparency went away. Sometimes it would reopen OK and other times it wouldn't. BUT changing RQ ALWAYS fixed it.

    There were still a few dozen more combinations I could have tried but I do have to sleep sometimes. ;) (I ain't no Leonardo yet)
     
  14. simonb65

    simonb65 Alibre Super User

    I can too confirm that using my geometry numbers in post #2, with a RQ of less than FINE, causes the face to disappear. Set the RQ to FINE and it appears. After that, changing the RQ does not make the face go away. So, the issue is the initial calculation/render of the face and the RQ that is selected at that time.
    Note : If the RQ is FINE before the part is drawn, it shows the face as expected.
     
  15. simonb65

    simonb65 Alibre Super User

    By FINE I mean ...

    upload_2018-5-15_14-11-15.png

    ... any other setting causes face issues.
     
  16. oldfox

    oldfox Senior Member

    My meaning also.
     
  17. oldfox

    oldfox Senior Member

    I couldn't chisel this statement in stone. I'll check that specific procedure in detail and get back to ya.
     
  18. oldfox

    oldfox Senior Member

    Well, I tried playing with it some more and now I can't make it fail.o_O:confused:
     
  19. dwc

    dwc Alibre Super User

    I can not cooberate this statement. For me it is _changing_ the facet resolution that will solve things _for the current part edit_.
    After saving the part and opening it again the resolution will need to be changed again. The resolution value is of no importance, it is making the change that does the trick.
    Don
     
  20. bigseb

    bigseb Alibre Super User

    This is generally what I get too.
     
    oldfox likes this.

Share This Page