1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems creating view orientations

Discussion in 'General Discussion' started by Toybuilder, Jun 21, 2020.

  1. Toybuilder

    Toybuilder Member

    I am having a weird behavior where I generally cannot create view orientations. This happens even when I start a fresh instance of Alibre, create a new part, rotate my view once and then go to the view orientation dialog with Ctrl+U (or through the ribbon).

    If you have Alibre running as you read this, can you see if it work for you? It is driving me absolutely batty with a current project where I need to work with custom orientations as my client is supplying me models that are not oriented nicely to the standard orientations.
     
  2. bigseb

    bigseb Alibre Super User

    Can confirm
     
  3. idslk

    idslk Alibre Super User

    Hello @Toybuilder,

    you're doing this:
    upload_2020-6-21_19-48-40.png

    and what you get is:

    upload_2020-6-21_19-49-5.png

    Then you should make the orientations window "longer":

    upload_2020-6-21_19-50-18.png

    Regards
    Stefan
     
    bigseb likes this.
  4. simonb65

    simonb65 Alibre Super User

    Yet another un-friendly UI dialog ... should have a visible vertical scroll bar on that list! Should have been tested ...
     
    bigseb likes this.
  5. bigseb

    bigseb Alibre Super User

  6. Toybuilder

    Toybuilder Member

    It is very inconsistent... See this:
     
  7. Toybuilder

    Toybuilder Member

    BTW, my problem isn't that I can't see the orientation in the list -- they are not showing up!
     
  8. simonb65

    simonb65 Alibre Super User

    Confirmed, the problem is that it allows you to go through the motions of Adding, BUT if the view orientation already exists, i.e. you haven't moved the model between selecting 'Manage View Orientations', it won't add your new view.

    I guess its to stop you duplicating views that already exist (be it in a different name!), but IT SHOULD TELL YOU THAT or ask if you want to rename the existing view to the new name or cancel the add!

    ...
    yet another un-friendly UI dialog ... Should have been tested ...
     
  9. DavidJ

    DavidJ Alibre Super User Staff Member

    Simon - that's what I thought when I originally looked at a recent support ticket - BUT, when I re-visited it later, the behaviour was different, I then could add duplicate orientations.... It seems to be more complex / random.
     
  10. simonb65

    simonb65 Alibre Super User

    Ok, it seems to let you add a duplicate if you perform a 'Set' first, but if you don't set a new orientation, it only lets you Add a single duplicate.

    DOES work ...

    • Manage View Orientations
    • Add

    or

    • Manage View Orientations
    • Set
    • Add
    or

    • Manage View Orientations
    • Set
    • Add
    • Set
    • Add
    • Set
    • Add

    DOESN'T work ...
    • Manage View Orientations
    • Add
    • Add
    or

    • Manage View Orientations
    • Set
    • Add
    • Add
    To fix the latter cases, the dialog needs to automatically set the new view after it's added it!
     
  11. simonb65

    simonb65 Alibre Super User

    Now, once you add the set before the add, or resize the dialog, the scroll bar also appears!
     
  12. Toybuilder

    Toybuilder Member

    OK, so I think I've worked out a TEMPORARY WORKAROUND. Before I create a new view orientation, I open the orientation dialog and set one of the pre-existing orientation and close the dialog. Then, I establish myself on a new orientation and then open the orientation dialog again to do an add.

    At least this appears to be a reasonably reliable way to get around this bug. In my testing so far, this seems to be fairly consistent and usable.

    Thanks everyone!
     
    simonb65 likes this.

Share This Page