1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PDFs and fonts

Discussion in 'Using Alibre Design' started by Hunter, Apr 24, 2020.

  1. Hunter

    Hunter Senior Member

    Alibre's built-in PDF creator (HOOPS 3D PDF) produces excellent quality quality PDFs, but it doesn't embed the fonts. It means that if you send the PDF drawing to someone who doesn't have that font installed on their system, it doesn't show on their side. They will only see dots and/or symbols. Strangely enough, if I produce a 3D PDF and choose to included some text, then it does embed the fonts.
    upload_2020-4-24_14-27-20.png upload_2020-4-24_14-33-15.png



    If I use an external tool to create the PDF (here I use FlexiPDF), it does embed the fonts, but the quality is not as good as the Hoops produced on. For example, the arcs and other curves appear jagged. Shaded views also come out as raster images (I see the shading has been fixed in V21).
    upload_2020-4-24_14-26-49.png
    upload_2020-4-24_14-32-29.png

    Is this a bug in Alibre and/or HOOPS, or is it only on my system? I've attached two PDFs that shows what I'm talking about.
     

    Attached Files:

  2. DavidJ

    DavidJ Alibre Super User Staff Member

    Check that all fonts needed are installed 'for all users' on your system. If they are installed for current user only, HOOPS can't access them when generating the PDF. I'm not sure that this is your issue, but it is something that is a known 'gotcha, and it is fairly easy to check & resolve.
     
  3. Hunter

    Hunter Senior Member

    Hi David,

    No, it don't think it can be that because HOOPS 3D embeds the fonts when I create a 3D model. I've also tested this by installing three new fonts from Dafont, same result, HOOPS doesn't embed.

    The same happens to Alibre drawing symbols, they don't get embedded.

    Could it be that I should install Alibre "for all users"? I've not tried that.
     
  4. DavidJ

    DavidJ Alibre Super User Staff Member

    I just checked in the Development issue tracker. Looks like this was a regression in a recent service pack from a technology partner - we are awaiting an update to resolve it.
     
  5. Hunter

    Hunter Senior Member

    Fantastic, you just saved me from trying a reinstall. Thanks for checking and for the feedback.
     
  6. EngineerJim

    EngineerJim Member

    Have there been any updates on this? We're having this problem at my company as well.

    Edit: Yes the problem is fixed in Alibre Design V22
     
    Last edited: Oct 15, 2020
  7. Hunter

    Hunter Senior Member

    Ja, it's fixed. Now also have proper vector geometry in the PDF, shaded views also displaying correctly.
     
  8. Max

    Max Administrator Staff Member

    Almost all PDF issues should now be done :D That's why we delayed v22 - we got a HOOPS update that addressed a bunch of this kind of thing and figured it best to make sure it was included.
     
    Mike Fleury likes this.

Share This Page