1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help With New Libary Function

Discussion in 'Using Alibre Design' started by RocketNut, Oct 16, 2020 at 2:44 PM.

  1. RocketNut

    RocketNut Alibre Super User

    I am a newbie to the library function, so please help.

    I am trying to insert the attached 2 parts to a library as shown in the attached screenshots.

    The bolt has a imported STEP I got from a website,. Can I save it in the library also?

    Also, where does the library file stored? I want to use it in a lot of designs.


    Libary Picture.jpg Dart Project 5 EFI M6 Wand.jpg


    Libary Picture.jpg
     

    Attached Files:

    Last edited: Oct 16, 2020 at 3:00 PM
  2. idslk

    idslk Alibre Super User

    have you taken a look in to the help file?
    upload_2020-10-16_23-14-45.png
    Regards
    Stefan
     
  3. RocketNut

    RocketNut Alibre Super User

    So how do I save the bolt in the library?
    According to the help files, I should see the bolt when I click on the M4 bolt, but nothing shows up.

    The part was attached to the first post on this thread.

    Dart Project 5 EFI M6 Wand #2.jpg Dart Project 5 EFI M6 Wand.jpg
     
    Last edited: Oct 16, 2020 at 9:15 PM
  4. Lew_Merrick

    Lew_Merrick Alibre Super User

    Sorry Stefan but I find no "help" in any of the "Help Files." It is like unto setting Material Properties in V22 -- a waste of time and effort. -- Lew
     
    JST likes this.
  5. RocketNut

    RocketNut Alibre Super User

    Lew what is there is very confusing and not very clear.

    I love the idea of the library because for it will make my life easier.
     
  6. JST

    JST Alibre Super User

    Regrettably, the help is regarded traditionally as something to be added later, and always gets rushed.

    In a sane development process, the help would be the FIRST thing written, so that the actual function as written must conform to it. The help would be essentially a definition of the function and how it is invoked.

    In that workflow, the initial help entry would be modified during development when the function needed modification, BEFORE the modification was done, so that it remains the "roadmap" of the function. The help would actually describe the real function, so it would actually be relevant.

    Unfortunately, "help" often does not, because there is info that "everyone knows" missing.... Well "everyone" may know it EXCEPT the folks who come looking at the help, who may be assumed NOT to know.
     
  7. idslk

    idslk Alibre Super User

    Hello Colleagues,

    there is an video on the Version22_Page
    upload_2020-10-17_8-48-21.png

    Regards
    Stefan
     
  8. RocketNut

    RocketNut Alibre Super User

    Yes I watch that video several times and did the steps ( along with help steps) as in the video without success.

    Could the problem with the bolt is there no parameters?
     
  9. idslk

    idslk Alibre Super User

    simply, yes. In your "Dart Project..." file are no parameters. Your "Thread M4..." should work.

    BTW.: There is a predefined database delivered, which could be imported...
    It was at my installation in the "Part Generator" folder, which is on level above the
    upload_2020-10-17_9-25-52.png
    which is reachable from The home window...

    If you go to import to library

    upload_2020-10-17_9-27-16.png

    and import the "Fasteners" (which may takes a while...)

    upload_2020-10-17_9-21-24.png

    You will get "demo parts" saved to your storage (HD, SSD...)

    upload_2020-10-17_9-30-46.png

    Regards
    Stefan
     
  10. DavidJ

    DavidJ Alibre Super User Staff Member

    An imported part won't work with Library, because it isn't a native Alibre model.

    Think of the Library as a way to save a design 'recipe' , that's the basic geometry for a part, an initial set of parameters, and rules for how those parameters might be set/altered/chosen from list when making a final part from the 'recipe'.

    When you go to use the Library - the values you choose are used to make a part based on the 'recipe' , you then save that in your project. You can subsequently edit that part, just like any other Alibre file.

    The Library items are stored in the Database Parts file (which won't exist until you have something in your Library).
     
  11. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Stefan -- And another example as to why "Help Files" provide no Help. -- Lew
     

    Attached Files:

  12. idslk

    idslk Alibre Super User

    Hi Lew,
    two comments:
    - have you been able to understand all your books at school without a teacher?
    - the help could be better, but if you are willing to read some information out of it, it is possible.
    Regards
    Stefan
     
    simonb65 likes this.
  13. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Stefan -- Books (at least when I was in school) had useful indexes -- something entirely missing from "Help Files."

    Try using the "Index" to find "Material Properties" -- I rest my case. -- Lew
     
  14. RocketNut

    RocketNut Alibre Super User

    Since I can not add imported fasteners to the library then I guess this new function is not going to work for me. :(:(:(:(
     
  15. idslk

    idslk Alibre Super User

    I've added a "dummy sketch" with a reference circle with a "dummy parameter", which allows me to add the part to the library.
    The "dummy parameter" is set to for example "2" and has no influence to the part.

    upload_2020-10-17_20-36-5.png

    upload_2020-10-17_20-37-23.png upload_2020-10-17_20-38-6.png

    Important Information! I found this without any index or help file!!;)

    Good Luck and Regards
    Stefan
     
  16. RocketNut

    RocketNut Alibre Super User

    idslk that sounds like a good workaround.

    I have a short screen capture video that shows when I tried it I was unsuccessful>>> https://www.dropbox.com/s/uegk8meknitt2ii/Library Function.avi?dl=0

    Sorry about the sound level I guess I had my mike setting to high. :oops:

    By the way I see in your screen shots you have a section called "Fasteners (ISO)". Where did you find them at? Maybe I can use them instead of imported fasteners.
     
    Last edited: Oct 17, 2020 at 3:58 PM
  17. idslk

    idslk Alibre Super User

    - Save your part (i don' tried if it makes a difference, but i have saved it with the dog bone on "lowest" postion / all refreshed)
    - choose "add to library"
    - check include the "dummy" parameter

    upload_2020-10-18_0-27-37.png

    - press next
    - enter a parameter value

    upload_2020-10-18_0-28-2.png

    - press next
    - choose a sub category

    upload_2020-10-18_0-25-29.png

    - I think that your "fault" was here. It looks like your were in mode to edit the name of the sub category. Then you left this mode and the subcategory wasn't highlighted any more, which causes the add to library to do do a (or not do) a save to nowhere.
    - be sure that a sub category is highlighted before you press finish!

    - press finish

    - choose "manage library"
    - take a look into the category

    upload_2020-10-18_0-26-24.png

    your part should be there.

    look into post #9 in this thread...

    Regards
    Stefan
     
  18. RocketNut

    RocketNut Alibre Super User

    I did all your steps and made sure the sub-category was selected when I click on the finished button. The high lighten sub-category icon de-high lights. and nothing happens. Checking the library manager there are no parts under the sub-category folder.

    Here is another screen video that shows I followed your to the letter>>>https://www.dropbox.com/s/uegk8meknitt2ii/Library Function.avi?dl=0

    Could I have a setting wrong?
     
    Last edited: Oct 17, 2020 at 7:06 PM

Share This Page