1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Keyshot 8 simply does not work at all now

Discussion in 'KeyShot for rendering' started by JST, Oct 13, 2020.

  1. JST

    JST Alibre Super User

    No Keyshot.... what's this about?

    I looked on Task manager, and when I click on KS, it shows up on the list, a little CPU activity is shown, then it stops, and KS disappears off the list.

    Sometimes, a message saying "(Suspended)" shows up on the KS line in Task Manager for a second or so before KS is wiped off the list.

    Is this indicative of a license issue? It looks like that, but I use Alibre Expert, and there ought not to be any issue with KS. Alibre is still working OK. No changes to AV programs recently, no files put in quarantine.
     
  2. DavidJ

    DavidJ Alibre Super User Staff Member

    Try this page at Keyshot
    https://luxion.freshdesk.com/suppor...7-my-keyshot-software-is-freezing-or-crashing

    If that doesn't help - try this (also from Keyshot), provided to a user who had similar issue.

    • Update your graphics card driver. To obtain the latest, visit the graphic card manufacturer’s web page. Download and install the latest driver updated for your card model.

    • Set permissions into the KeyShot resources folder.
    1. Go to your Documents folder
      • By Default :

        • C:\Users\UserName\Documents\KeyShot or

        • C:\Users\Public\Documents\KeyShot
      • Right-click the KeyShot folder

      • Select “Properties”

      • Disable “Read only”

      • Go to the Security tab

      • Click the Edit button. Ensure that all users have read and write permissions

      • Click Apply and OK

      • Click Apply and OK once more.
    • Turn off “Graphics Effects” under Edit > Preferences > Interface. Then, click Save Changes.

    • If you are unable to access the Preferences menu, then you may also turn off this setting inside the XML file:
    1. Open the Windows explorer and browse to your Documents folder

    2. Find the KeyShot9 folder and open it. Inside you will find KS9Settings.xml

    3. Right-click KS9Settings.xml and select to Open with > Notepad
    • Go to Edit > Find

    • Type the following in the search bar: “enable_gpu” or “enableGPU”, depending on your version, and click Next

    • In your document “enable_gpu” (or enableGPU) is highlighed.

    • In the same line you will see the word “true”.

    • Erase “true” and substitute with “false” (Note: everything else on that line should remain as is)

    • Save your changes and close the file
    • Now go ahead open KeyShot .
    • Restart your system, then go to Control Panel > System and Security > Windows Update and click “Check for Update”. Then install all the updates available.
     
  3. JST

    JST Alibre Super User

    And, for no reason, it is working today.

    But the really slooooowwwww zoom is still present. In close-up views, say around 1m distance in model space, the zoom seems to be in steps of 0.05mm per click, while at a larger distance, it is in fairly chunky fractional metres.
     
  4. simonb65

    simonb65 Alibre Super User

    Have you tried asking the question on the KeyShot Forums? ... probably more chance of people with shared experiences/issues than on the Alibre Forum.
     
  5. JST

    JST Alibre Super User

    I think I did register there, finally, after some trouble getting in.

    However, they seem to discuss the full version, naturally. I have the "Alibre only" limited version of Keyshot, and they do not seem to know much about it.

    IIRC I asked a couple questions, and got answers that were first, "use this feature" (that we do not have). And then when that was pointed out, it became "well you better ask over at the Alibre forum, because we don;t know anything about that version".

    So, finger-pointing both ways, and no answers.
     
  6. simonb65

    simonb65 Alibre Super User

    Its the same license limited version that ALL CAD bundles use. Same code, same issues regardless of what feature are enabled or not. If its user interface related, then the version its used on is most likey irrelavent and just causes the blame tennis game. Just tell them the issue, dont mention the licence level! You wouldnt mention the version if it was a zoom issue in Alibre ... its the same core code!
     
  7. JST

    JST Alibre Super User

    Well, when they suggest using a feature that does not exist, then you have a choice.... Shut up about it and "get advice elsewhere", or else tell the responders that your version does not have that, and have them INSTRUCT YOU to "get advice elsewhere".

    I went route #2, but they both end up at the same place......"get advice elsewhere".
     
  8. NateLiqGrav

    NateLiqGrav Alibre Super User

    My newest guess based on your posts is that some rendering setting is set way too high of detail/quality causing massive CPU overload. Dial back settings until it no longer causes stalling. You probably don't even need maxed settings if you are rendering billboards or 10 million dollar projects.
     
  9. DavidJ

    DavidJ Alibre Super User Staff Member

    You can ask Keyshot support - BUT make it clear to them when you ask that the problem is not related to activation (and hence isn't to do with the Alibre linkage). The information that I posted earlier was got via that route, but only at the second time of asking after it was pointed out that the issue was not activation related.

    In short - their default will be to say it's an Alibre issue, but they will help when it is clearly a Keyshot issue.
     
  10. JST

    JST Alibre Super User

    It SURELY has nothing to do with the linkage, since I NEVER use the linking.... I EITHER use Alibre OR I use Keyshot.

    Even having 12 CPUs does not seem to allow the two to work very well when used together.
     
  11. HaroldL

    HaroldL Alibre Super User

    JST, remember that KS uses every cpu core that is available at 100%. There should be a drop-down on the left side of the top tool bar labeled CPU Usage.

    cpu usage.png

    You can select a lower percent of cpu usage to free up some cores for other applications.

    cpu dropdown.png

    I generally have mine set to 50% - 63% (4 or 5 cores) and that allows me to use AD and KS at the same time with minimal slow down of either, and I only have 8 cores. Then when I need to render out an image I will crank it back to 100% without anything else running.
     
  12. JST

    JST Alibre Super User

    It should not come up as a problem..... KS uses multi-threaded, while AD does not, so the processor (singular) assigned to AD would not be affected by KS using every other one.

    My understanding is that AD CAN only use one processor, and that should mean KS is welcome to the rest unless the OS can use some.
     
  13. NateLiqGrav

    NateLiqGrav Alibre Super User

    Is your laptop plugged in or battery? Someone had a hardware issue where their laptop would drop cpu frequency because it was underpowered unless plugged in.

    Is your My Documents in a non-standard location and possibly a networked drive? Someone had that issue because temp files were taking forever to transfer before rendering.

    Still waiting on answers about settings. Too many samples and or ray bounces will drastically slow down the process.
     
  14. JST

    JST Alibre Super User

    Settings have been changed, just 12 ray bounces (down from 17), which was S.O.P. with the old 2 core machine and was reasonably fast. caustics, interior, self shadows shadow quality 1.5.

    Plugged in of course, it will not work with battery and KS, with the CPUs pulling nearly 40W, the battery is depleted fast. And, yes, the speed is reduced in battery, that is a known thing

    "My Documents" is wherever Windows put it. I do not use it for anything, don't even know where it is. MyDocs is a security risk.

    Pic of a typical render after a half hour or so. Still pretty granular, actually.
     

    Attached Files:

  15. HaroldL

    HaroldL Alibre Super User

    What is the rendered image resolution and are you rendering with Maximum Samples or Maximum Time? I've had renders that needed 250 samples to get a good image and it ran several hours.
     
  16. JST

    JST Alibre Super User

    Would have to look. Pretty much whatever I have used before on the old 2 core machine.

    1328 x 830 (actually 1920 x 1200 selected)

    The samples options seems not to be available in this version. I can see how many, but have no control. The entire "render" control drop-down is limited to a couple selections, the rest are grayed out.

    After 64 samples (4 min 30 sec), it looked like a newspaper photo. At 128, starting to look decent. (9 min). At 150, (10min 15 sec) looking "sorta ok", if switched to "photographic" mode. Attached is "basic" mode at 200 samples, still looks "magazine photo" to me, and not very good.
     

    Attached Files:

    Last edited: Oct 15, 2020
  17. HaroldL

    HaroldL Alibre Super User

    What options do you have available in the Render Options dialog? Likely not the full compliment of the Pro version but I would think that you should at least have control of Max Samples.

    rendersamples.png

    rendertime.png

    rendercustom.png
     
  18. JST

    JST Alibre Super User

    It looks as if they are all the same, actually, but they don't seem to make it any better.

    I may need to go play the blame game again and see if anyone over there can get past the version deal. If they don't suggest anything I don't have it will be OK. But the help is all oriented to KS9, and I am using 8, which I think is the last version we have access to (I have not checked recently).

    Highly likely the answers will be for 9 as well.

    Suffice it to say that the model and the real space are not behaving the same, despite good verified geometry. The model is of a real space I have access to. I am trying to make the rendering look like the space, as a way of increasing my understanding of KS.

    The rendering is quite coarse, and the lighting looks nothing the same. Light filtered through the perf metal lampshade is entirely different in reality than in the model and rendering.
     
    Last edited: Oct 16, 2020
  19. HaroldL

    HaroldL Alibre Super User

    You can find Help for previous versions on this page.
     
  20. idslk

    idslk Alibre Super User

    take a look HERE
    Regards
    Stefan
     

Share This Page