What's new

KeyShot 10 is out

slipstick

Member
I have Alibre Expert. If I just download the new Keyshot and install it, will Alibre see it, or should I wait until you guys have an update?
 

HaroldL

Alibre Super User
Don't be timid - Click Render on your Alibre model and see what happens. What's the worst that could happen.
 

DavidJ

Alibre Super User
Staff member
If you already have Keyshot for Alibre installed, and have current maintenance - it seems (based on my testing) that you can download Keyshot 10 from the Keyshot.com downloads page, install it and have Keyshot 10 take over from Keyshot 9.

If you don't have Keyshot for Alibre already installed, the Keyshot 10 installer form Keyshot site won't set up the linkage to the Alibre Expert licence.

All offered without warranty.
 

weppler

Member
I can confirm Keyshot 10 works with Alibre 22.
I downloaded/installed Keyshot10, then uninstalled Keyshot 9.
 

weppler

Member
I was wrong.

Keyshot 10 doesn't work properly with Alibre 10.
You can run it (10).. it seems to recognize the Alibre license, but the Alibre Render function fails.
K10 import fails and viewing bip's created in previous versions doesn't work very well.

I've reinstalled Keyshot 9
 

IonSteve

Member
Is it a massive improvement over 9.3?

In terms of the basic rendering engine, no. There may be things going on under the hood that I can't see, but the output appears the same. What IS improved is the new lighting control panel. If you ever tried to tweak lighting in 9.x or preceding versions, you know how tedious and frustrating it could be. They have now located most of the lighting controls in one place, made it stand-alone, and made them (a bit) more intuitive. There may be more things as well, but that was the first thing I found that had good immediate utility (and made me quietly whisper, "finally").

Steve
 

simonb65

Alibre Super User
I've noticed that both 9.x and 10.x generate a lot of debug error reports that get sent back to KeyShot (usually during startup of KeyShot). Not found the cause yet!
 

weppler

Member
I've noticed that both 9.x and 10.x generate a lot of debug error reports that get sent back to KeyShot (usually during startup of KeyShot). Not found the cause yet!

9 has been OK, but 10 on one of my machines asks to send a 53Mb error report EVERY time it launches???
 

MilesH

Alibre Super User
I was wrong.

Keyshot 10 doesn't work properly with Alibre 10.
You can run it (10).. it seems to recognize the Alibre license, but the Alibre Render function fails.
K10 import fails and viewing bip's created in previous versions doesn't work very well.

I've reinstalled Keyshot 9

My own experience for V23 was:

Installing KS V9.2 established link with Alibre
Installing KS V10 maintained link with Alibre
Uninstalling V9.2 and KeyShot 7 64 bit broke link with Alibre
Reinstalling KS V9.2 re-established link with Alibre
Installing KS V10 maintained link with Alibre
 
Top