1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I hate Alibre 2019

Discussion in 'Using Alibre Design' started by RocketNut, Oct 8, 2019.

Not open for further replies.
  1. RocketNut

    RocketNut Alibre Super User

    Last edited: Oct 8, 2019
  2. simonb65

    simonb65 Alibre Super User

    Are you running in Legacy mode? If not switch to that otherwise, if you switch back to 2018, you won't be able to open anything you've done in 2019!
     
  3. RocketNut

    RocketNut Alibre Super User

    How fo I swirchto "Legscy node"?

    Yes I know all the work I have done in Alibtr 2019 will not open in 2018, meaing that I have to redo all the work I done in 2029,
     
  4. simonb65

    simonb65 Alibre Super User

    System Options ...

    upload_2019-10-9_14-16-16.png
     
  5. RocketNut

    RocketNut Alibre Super User

    I will try that.

    Thanks for the tip. ( ͡° ͜ʖ ͡°)
     
  6. bigseb

    bigseb Alibre Super User

    Thing is, there are issues. I'm all for new additions and upgrades but 2019 has been a several steps backwards. It lags and glitches a lot. And other long-standing issues still haven't been sorted out. As users we should be critical of these things.
     
    pottersfriend likes this.
  7. KRELER

    KRELER Member

    Try to update to the 2019 SP1 version first (20.0.7.20065) which is available right now!!
     
  8. simonb65

    simonb65 Alibre Super User

    +1,
    I wouldn't mind spending more of my time beta testing prior to a release if it was better structured and maybe some incentive to deliver quality detailed feedback (i.e. maintenance waiver? ... as it does cost our time to test this for Alibre!) and into a bug reporting system that has visibility to those beta testing to see resolution progress. Also maybe Alibre need to put the question to the 'hard core' users as to what their priorities are for development. I know there is a suggestion scheme, but nothing ever seems to come of it and we get no feedback as to whether those are being considered, rejected, in development, etc.

    My #1 priority is and always will be stability, #2 Usability, #3 features. Without the first two, I start looking for other solutions as it directly impacts my working day and productivity ... and that costs me money!

    I understand the need to improve core components, but that should not be at the detriment to the product. For me, the HOOPS core should still be in development for a future release. 2019 should have just been stability, major bug fixes and added functionality that have been lingering for years. From what I've seen, the current path has actually caused more user issues than it has solved ... and I'm sure it's caused Max and the team more headaches than they really needed.

    In my opinion, 2019 in it's present form was released 6 months too early and wasn't methodically tested in house before it was released.
     
    Jake_Steidy, oldfox and bigseb like this.
  9. simonb65

    simonb65 Alibre Super User

    Even with SP1, 2D drawing text is still not vectors (still looks worse than 2018) ...

    upload_2019-10-9_20-14-11.png

    and lines are STILL drawn square ended! ..

    upload_2019-10-9_20-15-28.png

    Zooming on a 2D print preview takes forever and the quality is certainly not WYSIWYG ...

    upload_2019-10-9_20-18-59.png

    ... not even compared file sizes yet!

    Not sure what Alibre developers expectations of usability and quality are, but I'm sorry to say that they are a long way from mine!

    All this is in 2019 mode (not legacy).

    P.S. Sorry for the negativity, I'm sure it won't just be from me.
     
    kerickson likes this.
  10. bigseb

    bigseb Alibre Super User

    Agreed. In its current form 2019 is not ready for a design office or manufacturing enviroment. And that's a pity since some of the additions (particularly the new constraints) sound great.
     
    simonb65 likes this.
  11. Max

    Max Administrator Staff Member

    Simon, this looks like the 2D workspace (versus a PDF). Please confirm you have System Options > Display > Antialising - Drawings checked on.

    upload_2019-10-9_17-22-24.png

    HOOPS still has some issues with this on some geometry that are being addressed in their upcoming update. Please note that this feature is still in Beta, and perhaps you may want to disable it for the time being:

    upload_2019-10-9_17-15-16.png
     

    Attached Files:

  12. simonb65

    simonb65 Alibre Super User

    It was/is ..

    upload_2019-10-9_23-36-45.png
     
  13. Max

    Max Administrator Staff Member

    If that's the case then there is something else going on. Some things that come to mind are:
    - An external graphics profile, e.g. in video card settings, is forcing off AA
    - The graphics card itself or the driver used are having an issue

    I'll have Support reach out to you. Do you see antialiasing in 3D workspaces?
     
  14. simonb65

    simonb65 Alibre Super User

    @Max, now I've opened the System Options and viewed the already checked setting (I've not changed it) then exit the system settings and re-open a drawing, it now shows anti-aliased !!! I hadn't opened the settings in my first post ... so at what point does it read it and set it as being checked when upgrading from 20055 to 20065? (i.e. if the setting is not present at startup (because it didn't exist before), default to on OR default to off at startup because the setting doesn't exist, but the systems setting dialog creates the setting and sets it to on when opened?) you might want to look at your code there!
     
  15. Max

    Max Administrator Staff Member

    Glad we got to the bottom of it! Can I assume the text issue is now resolved?
     
  16. simonb65

    simonb65 Alibre Super User

    Err No! I don't think so, do you?

    SP1, AA on for drawings, non-legacy mode, (BETA) line widths OFF.

    This is the quality of text in my .pdf, at different zoom levels ...

    upload_2019-10-9_23-58-21.png
    upload_2019-10-9_23-58-39.png
    upload_2019-10-9_23-58-57.png
    upload_2019-10-9_23-59-22.png

    upload_2019-10-10_0-1-14.png

    upload_2019-10-10_0-3-11.png

    Text is NOT searchable.

    EDIT: This is using Print->CutePDF Writer, not the File->Publish to Print
     
    Last edited: Oct 10, 2019
  17. simonb65

    simonb65 Alibre Super User

    @Max, Can you post an example of what you see for 2D screen quality and PDF output please.
     
  18. simonb65

    simonb65 Alibre Super User

    Also once you check or uncheck the AA in Design setting and ok it, the outline of the design disappears until you change Edge and Face display to another mode and then toggle it back to the original display mode ... then the outline re-appears!

    These are simple QA tests @Max!
     
  19. simonb65

    simonb65 Alibre Super User

    Also, With a design loaded, toggle the design explorer off and then drag resize the application window width ... you get a band down the right side of the workspace window that is a duplicated portion of the main window (and its the same width as the design explorer was). So, some part of the drawing in the window is not taking into account the extra bit of client window space now the explorer has gone.
     
    Last edited: Oct 9, 2019
  20. Max

    Max Administrator Staff Member

    Simon,
    For PDFs, how are you making them? File > Publish to PDF?

    Or are you using a print to PDF driver?

    Regarding some of your other points, those aren't reproducing so perhaps there is something specific to your hardware or driver.

    We spend a lot of time QAing but there are always gotchas with combinations of hardware and drivers that we just don't have. Our most infamous example is someone couldn't print no matter what, made no sense. Turned out a mouse driver of all things was notorious for interfering with programs. What I suggest is that we treat this initially as a support case where we can get "the body of work" of issues you are seeing and then try to figure out the root cause.

    We aren't over here watching horrible bugs all day going, "meh, ignore it." Some things we cannot do anything about but wait for partner updates. However I understand and sympathize with your frustration so let's get to the bottom of it together. Hopefully it is something simple that will resolve the majority of your issues.
     
    bigseb likes this.
Not open for further replies.

Share This Page