1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to find Missing Geometry

Discussion in 'Using Alibre Design' started by dsage, Jun 24, 2020.

  1. dsage

    dsage Senior Member

    It's inevitable when I add / remove parts and change constraints when I create and fine tune a very complex assembly that I end up with axis and other geometry that I've added to constrain with that some become orphans.
    My question is how do I delete these. I get this errors if I try. I suppose they must still be attached to something but how do I figure out what. I've tried expanding all the constraints but the offending axis' do not show up in any of them. I could just leave them but I like to keep things looking nice and clean.
    It's another one of those things that drive me crazy.


    upload_2020-6-24_17-20-56.jpeg
     
  2. idslk

    idslk Alibre Super User

    Hello dsage,
    if you only wanna get rid of the axis: RMB on Axis and choose "Edit", here choose eg XY-Plane and YZ-Plane, hit ok. Then you should be able to delete the Axis.
    Regards
    Stefan
     
  3. dsage

    dsage Senior Member

    I think you meant to select an X or Y axis not a plane. A plane is not an acceptable option to define an axis (OK does not activate).
    In any case selecting an axis got rid of the red error color of the axis and the status shows no errors for it because I guess Axis 3 is now the same as the X-axis I selected to assign it to. But if you right click on it delete is grayed out so I still can't delete it.

    I couldn't take a screen shot of the greyed out edit because the dialog box disappears when you activate the clipper.

    upload_2020-6-24_20-42-47.png


    upload_2020-6-24_20-35-17.png
     
  4. HaroldL

    HaroldL Alibre Super User

    That's because it is "used" in a feature or sketch and can't be deleted until that relationship is removed. You need to find the feature/sketch that is referencing the axis and select a different reference axis for that feature. The axis can then be deleted.
     
  5. bigseb

    bigseb Alibre Super User

    Off-topic but fyi: print screen, paste in paint then trim/crop as you like.
     
  6. simonb65

    simonb65 Alibre Super User

    It does that if you use the 'clip now' normal operation, but if you use 'snip', built into windows, you can set a timer (say 5 seconds) which will allow you to capture all windows states including context menus, popups, etc. The timer triggered snip doesn't dismiss any active windows, so you should be able to capture your dialog. Once captured, you can select the region as you would normally.
     
  7. Hunter

    Hunter Senior Member

    Download Greenshot for screenshots, it has some added functionality
     
  8. idslk

    idslk Alibre Super User

    No, i meant 2 Planes. :)
    If you've done something like this (axis on an edge):
    upload_2020-6-25_16-9-42.png

    and then you do this (delete the part with the edge):

    upload_2020-6-25_16-10-47.png

    you will get this (an axis without a source):

    upload_2020-6-25_16-11-41.png

    then you can do that:

    upload_2020-6-25_16-12-27.png

    or (see eg.) 2! other planes (it's easy to use to origing planes because the are available and you don't have to think about)

    upload_2020-6-25_16-13-28.png

    hit "OK" and you will have an axis without the red cross...

    upload_2020-6-25_16-14-2.png

    This one you can delete...

    upload_2020-6-25_16-14-41.png


    Conclusion: using part geometry as reference needs more to take care about. ;)

    Regards
    Stefan
     
  9. dsage

    dsage Senior Member

    I must still be missing something here. As you can see I selected two planes as you suggested and the axis red goes away.
    If I right click it Delete is still not an option. (probably because it's used - don't know)
    As for the comment on it's a matter of finding were the axis is used and eliminate the usage - that goes back to my first post.
    How do you find where the axis is used.
    As explained I've expanded the (hundreds of) constraints and didn't see the axis usage. Sometimes it's easy when it's red but in this case it didn't show (at least I didn't see it). Now that it's grey again you can forget about finding it.




    upload_2020-6-25_16-56-5.png




    upload_2020-6-25_16-55-16.png
     
  10. dsage

    dsage Senior Member

    Ok I figured out how to track down the offending axis. (while it was grey). I expanded all the constraints first. Then went up and clicked on the offending axis and then leaving it selected I scrolled down through the expanded constraints and the axis was highlighted. The constraint wasn't doing anything properly anymore (but it wasn't red either) so I deleted it and the axis was then able to be deleted. I guess if the axis was used in more than one constraint you'd have to clean up (or deleted) all the constraints using the axis and then you can delete the axis.
    Not sure if any of the above is true if the axis is red.
    Problem solved until I run into it again.
    Thanks for the tips.
     
  11. idslk

    idslk Alibre Super User

    Hello dsage,

    there has been a thread by you with such a problem like this...
    Old Thread
    May you should have tried this first...:)

    Regards
    Stefan
     
  12. dsage

    dsage Senior Member

    Maybe.
    But I really have no interest in running a script (as was suggested in the first thread) nor should I need to be a programmer to write one to work-around something that should be doable with the standard tools.
    Now that I know the trick (figured out above) I MIGHT remember it and won't have to find and use an obscure work-around script.
     
    Last edited: Jun 26, 2020
  13. idslk

    idslk Alibre Super User

    ???
    Regards
    Stefan
     
  14. dsage

    dsage Senior Member

    Yes. I knew nothing about it until you put it in your post. I gather that you wrote it yourself so it wasn't readily available in Alibre to my knowledge. I just use the standard interface. I have no knowledge about scripts and couldn't write one if I need to.


    upload_2020-6-27_16-11-42.png
     
  15. idslk

    idslk Alibre Super User

    yes, because you had an issue and i thought this tiny little tool could help you.:)
    No problem at all, there are some forum members who will do this only to help.
    Three is a Thread called Alibre Script - script requests where other users can ask if somebody can write a script for a special task...
    Btw. i would also find it usefull if the user gets a little warning from the standard interface if he's going to delete a used reference...

    Regards
    Stefan
     

Share This Page