1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

how to discard edits

Discussion in 'General Discussion' started by rastro, Jun 26, 2018.

  1. rastro

    rastro Member

    I have been modifying an assembly over a period of time. Now that I am ready to save it, i click the save button, and it lists 2 items. The assembly that I am interested in saving and another component part of the assembly that I don't remember editing. I want to toss the changes to the part while saving the assembly. The logical thing, to me, is that one of the options under 'save actions' would be 'discard'. That doesn't exist.

    what is the best way to accomplish this ?

    thanks.
     
  2. dwc

    dwc Alibre Super User

    I think that sometimes AD wants just to update the thumbnail picture or something like that.
    You have two possibilities,
    1) accept that the file will be updated.
    2) change the name of the file,save, and then delete it.
    When you next open the assembly the file will be missing and you can tell it to use the original file.
    A pain, but it works.
    Don

    (note that it is because of this behaviour that it is impossible to have a library of standard parts in AD. AD requires that all files be read/write. I hope they will be finding a solution to this problem that AD has always had and that I have often complained about soon. Just this one problem makes AD unusable in many companies. It must be possible to have standard parts that are never changed.)
     
    Last edited: Jun 27, 2018
  3. simonb65

    simonb65 Senior Member

    +1

    All my parts are stored in a version control system and its a pain when standard parts, i.e. nuts, bolts, screws, washers, etc are 'changed' as the version control system then needs you to check them all back in (and 'up issue') or manually go through each one getting the original back out of the repository! A right royal pain in the backside.

    It could be solved by just referencing the sub part/assembly until and edit is made, even at that point, the original parts should have the option to be copied before the edit so that other products/assemblies using the part are not impacted. If the part being added to an assembly is a read only part, it should not allow editing or saving.

    Just my £0.02 worth!
     
    jfleming likes this.
  4. Lew_Merrick

    Lew_Merrick Alibre Super User

    In my experience, a Part (or Sub-Assembly) is not "changed" when Saving an Assembly unless that Part (or Sub-Assembly) has been changed within the context of the Assembly. The problem I face is making a Revision Change to a Part or Sub-Assembly and changing it's name to agree (by changing (say) Rev New to Rev A in that file's name).
     
  5. rastro

    rastro Member

    well, back to the drawing board ?! Accepting the fact that i will have to save both pieces I went ahead and tried to save them both.
    I get this error ..

    upload_2018-7-2_20-29-54.png

    There is plenty of disk space, I can open another part (file) from the same directory I am trying to save to. what gives? I have opened and editted parts from the same directory and saved them. Yes this is a networked directory.
    If i try the change the file name I can't. The save action is stuck to modify.

    This is silly. Is this a new release thing or my bad luck?
     
  6. simonb65

    simonb65 Senior Member

    Do you have Windows Search enabled for mapped or shared network drives? This issue is sometimes seen if your PC is trying to index the remote network drive at the same time your applications are trying to access files on it! Go to Window Search and ensure that anything not local to your PC is excluded from the Search Indexing or just stop the Windows Search Service full stop!
     
  7. Lew_Merrick

    Lew_Merrick Alibre Super User

    I am not sure if this would be of use to you, but on my system I have assigned the hotkey "^W" (that's Cntrl+W) to abandon work. You will have to answer "No" to Saving Changes and exit, but it works for me.
     

Share This Page