1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DXF Files

Discussion in 'General Discussion' started by Happycamper, Sep 5, 2019.

  1. Happycamper

    Happycamper Member

    I made an explicit reference that I needed to import and export DXF files. I cannot find anywhere in Alibre anything referencing anything DXF . I would like someone to explain where I need to go in order to utilize DXF files. I purchased Alibre Expert within the last two weeks.
    Thanks in advance
     
  2. Max

    Max Administrator Staff Member

    File > Open > DWG/DXF > opens the file in a 2D workspace

    From a 2D workspace: Have a drawing open > File > Export > DWG/DXF
     
  3. Killiwatt

    Killiwatt Member

    Except when I open up "File" and by "File" I'll assume you mean the "A" gem in the upper left corner of the screen and select "Export", there is no option for DXF/DWG. In fact, of the options available, none of them are remotely useful for any program that I run in my shop.
    Help?
     
  4. bigseb

    bigseb Alibre Super User

    Are you exporting a part or a solid? You need to export from a drawing. And get this:

    Capture.JPG
     
  5. Killiwatt

    Killiwatt Member

    I'm in trial here trying to decide if I want to switch from Vectorworks to be clear.
    So if I understand you correctly, I need to design the part, then create a drawing from the part which will allow me to export to DXF so that I am able to import this DXF into Aspire and generate a toolpath from that.
    Why not just be able to export the part as a DXF?
     
  6. Killiwatt

    Killiwatt Member

    So when I create a drawing from the part and do the export to DXF as you suggest, when I try to open it in Aspire it shows "no data". I then tried to open the file with Solidworks and get the same thing.
    Thoughts?
    Appreciate your input.
     
  7. bigseb

    bigseb Alibre Super User

    You're new to AD?

    That's not how AD works.

    Could just be the version of dxf you select. See what Aspire can read.
     
  8. Killiwatt

    Killiwatt Member

    I tried both 2014 and 2018 both of which I can import from Solidworks no problem.
    This is a deal breaker for me at this point. Disappointed as I really like the interface.
     
  9. Killiwatt

    Killiwatt Member

    Yes I'm new to AD.
    Sorry, just saw that question.
     
  10. Lew_Merrick

    Lew_Merrick Alibre Super User

    DXF is typically a 2D Only format. A Drawing is a 2D Representaion whereas a Model is 3D. The "loss" in 3D transformations is that the sequence that created a 3D Part or Assembly is lost during the transformation. You can than Dassault and Autodesk for this...
     
  11. bigseb

    bigseb Alibre Super User

    It might be worth while getting in touch with Alibre. They might be able to help you with this.
     
  12. Killiwatt

    Killiwatt Member

    Thanks, I'll see what they say.
     
  13. Max

    Max Administrator Staff Member

    Yeah, ping hello@alibre.com - I think this is likely a training issue that could be solved with a quick screenshare.
     
  14. DavidJ

    DavidJ Alibre Super User Staff Member

    Quite lot of CNC software works with older DXF versions, not the newer ones. Perhaps try exporting in an older DXF format.

    One check for 'silly' errors along the way - can you re-import the DXF back into Alibre, does it give what you expect? If it doesn't, then more investigation is needed.
     
  15. KMoffett

    KMoffett Senior Member

    I have exported DXF files from Alibre Design Expert 2018.2 and imported into Aspire 9.5. I don't recall what version DXF I selected in Alibre.
    Ken
     
  16. KMoffett

    KMoffett Senior Member

    I exported an Alibre Design drawing in all the .dxf formats shown in bigseb's post #4. I was able to import all into Aspire, though the AutoCad 14 gave me an error:

    "Cannot set CTABLESTYLE to that value.
    Do you want to continue processing the file?
    Yes...No"

    Pressing Yes continues the import OK.

    Ken
     
    bigseb likes this.

Share This Page