1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

display thread not completely

Discussion in 'Using Alibre Design' started by tedag, May 13, 2020.

  1. tedag

    tedag New Member

    Hello,

    I've only been using alibre recently. I still have a problem with the representation of threads in assemblies. If a part (e.g. screw) is partially covered, the thread is still displayed completely. Can anyone tell me what I need to adjust to change this? So that only the thread is shown which is visible in the view.

     
  2. albie0803

    albie0803 Alibre Super User

    This is a problem with showing threads. The only option is to not show threads and put the thread lines in manually.
    I have requested this that threads only show when visible but nothing has come of it yet.
     
  3. tedag

    tedag New Member

    Oh, that sounds bad. Especially with large and changing assemblies it makes the effort unnecessarily large. I don't understand why Alibre can't do it. The creation of drawings according to international standards should be possible for such a comprehensive CAD system.
     
  4. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Tedag -- What I see is that the "OD of the Screw (or BolrI)" is not being shown in appropriate "Hidden Line" display. -- Lew
     
  5. albie0803

    albie0803 Alibre Super User

    No Lew, the opposite. It's the thread line being shown where the bolt can't be seen is the issue
     
  6. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Albie -- But if the Thread is shown, should not the "edges" of the Bolt/Screw be shown as Hidden Lines??? -- Lew
     
  7. JST

    JST Alibre Super User

    The issue is that the edges are not supposed to be shown, and the thread minor diameter should not be either.

    BOTH should be hidden, but the view rendering apparently does not "consider" the thread indication line.
     
  8. tedag

    tedag New Member

  9. Lew_Merrick

    Lew_Merrick Alibre Super User

  10. albie0803

    albie0803 Alibre Super User

    In any view, either part or assembly, if the thread can't be "seen", then it shouldn't appear when threads are called.

    If I section a flange through a threaded hole, the thread should show but not any of the other threads, which happens now.

    If I show the end view of a shaft that has threads on both ends, I should only see the thread for the end in the view, not both which happens now.
     
  11. HaroldL

    HaroldL Alibre Super User

    I think that the reason that cosmetic threads don't "hide" when you turn off Hidden Line Display is because they are annotations - note the symbol by the mouse pointer in the attached image. Place any other annotation, weld symbol, surface finish, theoretical intersection, on the drawing and you'll see the same mouse icon for them.
    Looks like you'll create a hidden layer to put them on - just one more thing to take up your time.

    LineType For Cosmetic Threads.png

    Just a side note that the same "problem" exists in SolidWorks.
     

Share This Page