1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dimension Text in my Sketch is HUGE

Discussion in 'General Discussion' started by ericle, Nov 14, 2019.

  1. ericle

    ericle Member

    I opened an existing assembly to add a part. So, I created a new part and when I go to place dimensions on the sketch the size of the dimension text is literally filling my screen. It is HUGE. I went to the properties and adjusted the font size to 8 and it barely made a difference.

    Has anybody else seen this and if so, how did you fix it??

    I can't design like this.
     
  2. NateLiqGrav

    NateLiqGrav Alibre Super User

    What Alibre version are you on?
     
  3. OTE_TheMissile

    OTE_TheMissile Alibre Super User

    Just to clarify, when you said you went into Properties to change the text size, do you mean you right-clicked on a dimension in the Sketch and edited its Dimension Properties, or you went somewhere like the File menu and found the text size in File Properties?

    Because if you changed Dimension Properties, that's only going to affect that one individual dimension that you right-clicked on. Changing the text size in File Properties should (emphasis on "should") change all the Sketch dimensions.
     
  4. ericle

    ericle Member

    2019 [Build 20065]

    I have uploaded a screen shot. That is the placement of ONE dimension. Alibre_HUGE FONT ISSUE.JPG
     
  5. ericle

    ericle Member

    I changed it in the menu, where it will effect all dimensions.

    I don't know what is going on but this is ONLY happening with STEP file that I imported from Solid Edge. It is working properly if I create a new PART and then start the design process.
     
  6. NateLiqGrav

    NateLiqGrav Alibre Super User

    Please report and send the file to Alibre support.
    In the mean time you can try the check box to "Use Legacy Display" on the Display > General tab in the Options.
     
  7. Max

    Max Administrator Staff Member

    This is very odd. We'll investigate this. I don't think we've seen this from anyone else's workflow at this point, so perhaps it is unique to SE imports.
     
  8. simonb65

    simonb65 Alibre Super User

    What scale did you import the model as? It maybe that the text is the correct size, but the model is very small!! Have you used the measure tool to check the model scale?
     
  9. OTE_TheMissile

    OTE_TheMissile Alibre Super User

    He's dimensioning a Part sketch though, not a Drawing, so the dimension font size should scale itself appropriately to whatever zoom level he's at.
     
  10. simonb65

    simonb65 Alibre Super User

    There seems to be some fundamental issues with dimensions in sketches, the values you can set on Properties->Dimensions with regard spacing are not honoured. Also when you drag a dimension (the 0.234 mm below) the drag 'bounding box' is totally the wrong size for the bounds of the text its actually displaying, yet the dimension spacing do seem to be related to the 'wrong' bounding box (in green) ...

    upload_2019-11-15_15-45-45.png

    Plus the scale set by the dimensions (in mm) does not seem to relate to the screen display. i.e DPI doesn't seem to be used to render it!
     
  11. bigseb

    bigseb Alibre Super User

    No-one asked this yet so here goes: can you share the files so we can check repeatability?
     
  12. TimoCAD

    TimoCAD Senior Member

    What is the name of your font? Nice.
     
  13. simonb65

    simonb65 Alibre Super User

    That is 'Miso'. I sometimes use 'osifont' for drawings or documentation too, but Miso is nicer.
     
    TimoCAD likes this.
  14. DavidJ

    DavidJ Alibre Super User Staff Member

    This effect occurs with editing in assembly, when the model units are different between assembly and the part being edited. It is already logged with Development for attention. A workaround is to switch to Legacy Display mode.

    Basically the scaling gets messed up because of the different units. Typically you'll only have different model units (i.e. not cm) from an import.
     

Share This Page