1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Design Explorer Assembles's Part Properties

Discussion in 'Using Alibre Design' started by GIOV, Sep 1, 2020.

  1. GIOV

    GIOV Alibre Super User

    Hi all,
    I am trouble to assign material properties to a big assemble model that need find its cg. I think that AD doesn’t have the capability of assign this thought the Design Explorer branch mode select by mouse. What is the faster process for avoid go for each part of all Assembles?
    Thanks in advance.
    GIOV
     
  2. Lew_Merrick

    Lew_Merrick Alibre Super User

    Giov -- Material definition is an element of Part definition -- and not assigned at the Assembly level of operations. If your Parts are correctly defined than your Assembly Mass Properties will come out right. [I have a customer who insists on defining Material Density as being 1 lb/in³ -- and then wonders why his "weights" are never even "close." -- Lew
     
  3. GIOV

    GIOV Alibre Super User

    Lew,
    I understand, but I received a model that has many parts in STP file that I need assign it material properties so I thinking on the Design Explorer for do this faster that involve a lot of parts that have same material in one assemble.
    upload_2020-9-1_12-40-43.png
     
  4. Hunter

    Hunter Senior Member

    You'll have to do it one by one, I don't know of another way. Ideally one should be able to assign material properties via the BOM, or right-click in the explorer as you tried. Hopefully in future...
     
  5. idslk

    idslk Alibre Super User

    Hello Giov,

    only Parts or also Subassemblies?
    It is possible with scripting...

    Regards
    Stefan
     
  6. GIOV

    GIOV Alibre Super User

    Yes Hunter, Hopefully in the nearest future...
    Excellent , Do you have an example for many parts and assemblies for know the the right procedure? As you know I am not a programmer. Also waiting for your 2D & 3D Points in wizoScript 4.10 :)
    Thanks,
    GIOV
     
  7. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Giov -- Now, (A) I would not suggest that Stefan could not come up with a Script for such a thing, but (B) my experience with (shall we say) STEP Assemblies is that I have to Open each Part or SubAssy within it, assign Material Properties to it and Rename it to a useful and meaningful File Name -- and (C) regenerate the entire Assembly and SubAssy set(s) to make it useful. -- Lew
     
  8. GIOV

    GIOV Alibre Super User

    Waiting for Stefan. May be he has a big surprise in this...
    Well I understand. It is the procedure that right now I am doing in AD but In Rhinoceros you are able to select the assemble and assigned the Material Specification by Area or Solid. In certain case is a lot of more productive. I do like AD have the same thing now...
    upload_2020-9-1_18-27-18.png

    upload_2020-9-1_18-20-36.png

    Edited.
     
    Last edited: Sep 1, 2020
  9. idslk

    idslk Alibre Super User

    Do you want to assign the same material to all parts or do you want to assign the material only to the selected parts in explorer?
    Regards
    Stefan
     
  10. GIOV

    GIOV Alibre Super User

    Both possibilities but the preference is assign the material only to the selected parts in explore.
    Thanks in advance,
    GIOV
     
  11. idslk

    idslk Alibre Super User

    Hello GIOV,

    as far as the new alibre material library (and how it could be used in scripting) isn't available, their will be a "limited" access to materials (defined in the script).
    I will look to post a test version within the next few days.

    Regards
    Stefan
     
  12. GIOV

    GIOV Alibre Super User

    Thanks very much Stefan,
    GIOV
     
  13. idslk

    idslk Alibre Super User

    Hello GIOV,

    here's the first shot to play with it...
    i havn't done so much evaluation...
    it's only for test purposes.
    Comments are welcome.
    If you want to use it only on selected parts, you have to select the parts in the explorer before you run the skript.
    It runs through the complete assembly including sub assemblies.
    upload_2020-9-6_0-16-18.png

    "As ever", script use on own risk.

    Regards
    Stefan
     

    Attached Files:

  14. GIOV

    GIOV Alibre Super User

    Hi Stefan,
    Good inspiration!
    I will run the script asap making a comparative result from other source and let you know.
    Thanks very much for you efforts.
    Giovanni
     
  15. GIOV

    GIOV Alibre Super User

    Hello Stefan,
    Your Script still doesn't run in my Alibre VersionV21Assemble Drawing. May be need wait until AV22:)
    Alibre Design™ Expert
    Version: V21 64-bit [Build 21034]
    File "<string>", line 32, in <module>
    IOError: System.IO.IOException: file does not exist: C:\Program Files\Alibre Design\Program\AlibreX.dll
    May be is the line 32
    32 clr.AddReferenceToFileAndPath(r'C:\Program Files\Alibre Design\Program\AlibreX.dll')
    Regards,
    Giovanni
     
  16. DavidJ

    DavidJ Alibre Super User Staff Member

    GIOV - is your Alibre Design installation in the default location? If it is in a non-default folder, you'll need to modify that AddReference... call to match where AD is installed on your computer.
     
  17. idslk

    idslk Alibre Super User

    Hello Giovanni,
    it's like David said. It looks you have Alibre installed in a "non standard location".
    I hope the appended version 0.11a can fix it without forcing you to change the script code by yourself.
    Regards
    Stefan

    Edit: Found that an error occurs, if script is started while the assembly is in part edit mode. fixed ;-)
    Also added a new material :))
    I've changed the version to V0.12a
     

    Attached Files:

    Last edited: Sep 8, 2020
  18. GIOV

    GIOV Alibre Super User

    You right. I install the AD by Version folder. I will correct the path.
    Yes. Also your last script isn't able to download in my machine.May be by zipped folder is better & safe.
    I will let you know the result asap.
    Regards and thanks very much,
    GIOV.
     
  19. idslk

    idslk Alibre Super User

    What's the failure message downloading it?
    But anyway a zip is appended
    Regards
    Stefan
     

    Attached Files:

  20. GIOV

    GIOV Alibre Super User

    Something is wrong in my machine. It does a quick blink when I try to download a file from the forum. This is a recent issue.???
    I will try later after reboot it.
    Thanks Stefan.
     

Share This Page