1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Constraints lost on packaging / unpackaging

Discussion in 'Using Alibre Design' started by cdpatten, Feb 5, 2020.

  1. cdpatten

    cdpatten New Member

    I have a collection of parts (AD_PRT files), an assembly (AD_ASM file) and a drawing (AD_DWG file). I open up my AD_DWG and create a package (AD_PKG). Then I restore the package (in a different location). Almost everything seems to work. All of the files seem to unpack, the drawings look okay, the assembly looks okay. However, in the assembly, a few of the constraints have gone red. The act of packaging and un-packaging had some unintended consequence of messing up those constraints. What is the best way to attack/investigate this problem?
     
  2. bigseb

    bigseb Alibre Super User

    Have you tried refreshing (F5)?
     
    cdpatten likes this.
  3. cdpatten

    cdpatten New Member

    Schaaa-wing indeed. No I had not tried that and yes, it worked.
     
    bigseb likes this.
  4. OTE_TheMissile

    OTE_TheMissile Alibre Super User

    I get that on odd occasion just opening my own Parts and Assemblies on my work machine. No idea why but a refresh and a Save usually solves it.
     
  5. simonb65

    simonb65 Alibre Super User

    Is it caused by one of the sub-parts/sub-assemblies not being regenerated to the bottom of the feature tree? If something gets saved and isn't fully regenerated, any references used byb other files (assemblies) that are after that point get broken! It's happened to me doing in-place-editing or sub-component edit and not done and F5 before closing/exiting the edit! If this is the case, then there have been a few suggestions to add an option to effectively 'auto F5' before the actual Save/Close to stop this inadvertently happening.
     

Share This Page