1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can anyone interpret this ERROR message for me?

Discussion in 'General Discussion' started by VoltsAndBolts, Nov 15, 2019.

  1. VoltsAndBolts

    VoltsAndBolts Senior Member

    Can anyone interpret this ERROR message for me?

    Trying to save an imported STEP assembly with no luck. Is it just to big?


  2. JST

    JST Alibre Super User

    I have seen that one a few times. Not on big assemblies either.

    Absolutely zero idea what it means, but that is typical for Alibre error messages.
    anson likes this.
  3. bigseb

    bigseb Alibre Super User

    I've had that too several times. Not sure what causes it though.
  4. DavidJ

    DavidJ Alibre Super User Staff Member

    Are you trying to save to a network location? If so try saving locally to see if that helps.

    Also could be a geometry problem with a specific component.

    Also if not already done, try re-booting PC and repeating.
  5. slipstick

    slipstick Member

    You might look at the names of the parts in the assembly - maybe there is some illegal character in some or all of them? When I'm coding, I might see this error if I have tried to access an object that I haven't created beforehand. Perhaps an illegal character is preventing Alibre from doing something before it saves the assembly.
  6. oldfox

    oldfox Alibre Super User

    Have you tried by opening AD with "Run as Administrator"?
  7. JST

    JST Alibre Super User

    For me, when I got that, I just tried again, and often/usually it worked. So, it could not have been anything really wrong with the file.
  8. VoltsAndBolts

    VoltsAndBolts Senior Member

    I have tried several times.
    Closed all programs and rebooted.
    Same error. It could be related to part names. The original file is from China

    I guess I can try renaming all the part files... not looking forward to that....
  9. DavidJ

    DavidJ Alibre Super User Staff Member

    Have you tried different import options?

    Can you tell what software the file originated from (look at STEP file in a text editor).
  10. jhiker

    jhiker Alibre Super User

    Does your assembly have sub-assemblies? If so can you open and save the sub-assemblies separately without an error? Might help you focus on the 'bad' part of it. I'm surprised Alibre can't give us some indication of what it might mean.
    anson, JST and VoltsAndBolts like this.
  11. lamar

    lamar Senior Member

    I have seen this also when i try to save to a network. It was usually a file that was locked or open. sometimes it was a file that was included in the assembly that was highlighted in the widows folder. sometimes doing a Save AS and using a different name would work and then at a later date i would save to the original name again.

    I hope this is of a help.
  12. simonb65

    simonb65 Alibre Super User

    I've seen this on network drives many times too. It's commonly caused by my NAS doing its caching or raid operation or the drive is asleep and just needs time to wake and spin up. I've also experienced it with virus checkers which scan files on access, expecially when they are first created. Generally, windows should handle these scenarios, but in this case it looks like Alibre or the ROSE engine just isn't handling the exception that is being presented to it! So a few possible causes, but Alibre could do way better at handling it and at least telling you gracefully why it can't complete the operation or just wait and retry when the file can be opened for writing.
    Last edited: Nov 20, 2019
    anson and cadtec like this.
  13. VoltsAndBolts

    VoltsAndBolts Senior Member

    Just thought I would post an update on this.

    After the most recent Alibre update the file imported and saved without incident. The file names are gibberish but I can rename them.

  14. Lew_Merrick

    Lew_Merrick Alibre Super User

    Hi Rob -- Let us assume this is an Assembly (call it "Assy01") made up of (say) Part_01, Part_02, and Part_03. Further, let us say that Part_01 is a "Mounting Plate" and Part_02 is an "Index" and Part_03 is a "0-2500-28UNF-2B X 0-500 Long Hex Head Cap Screw." So after you Save "Assy01" it creates Part files: "Part_01," "Part_02," and ""Part_03" I usually create Sub-Directory named "Reload" below the Directory where the "imported File" was saved. I Copy the "Part_0x" files to the "Reload" directory and Rename them to a (if you will) "more descriptive name" (as described above). Then I Open each file in Alibre Design and perform a SaveAs command and Overwrite each file to make it "readable" to Alibre Design. I often find that I need to "Regenerate" the Part Files so created to eliminate "bad geometry" (which will require it's own SaveAs and Overwrite command). Now I can re-create Assy01 with a (if you will) "more descriptive Name" and continue on. I hope this helps you. -- Lew

Share This Page