1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BOM showing up empty (no entries)

Discussion in 'Using Alibre Design' started by Hunter, Oct 15, 2020.

  1. Hunter

    Hunter Senior Member

    I have this annoying issue with a few drawings where my BOMs keeps showing up empty if I open the drawing after I worked on it, saved and closed it. I can only see the grid of the BOM, but no text entries. Reprojecting views doesn't help. I've deleted and recreated the BOM, but the problem persists.

    To get the BOM working, I have to reinsert the BOM every time.

    What am I doing wrong, or what am I missing?
     
  2. DavidJ

    DavidJ Alibre Super User Staff Member

    By re-insert, do you mean re-create, or re-link ?
     
  3. Hunter

    Hunter Senior Member

    Delete the old BOM, recreate it, insert it again. That works fine, but if I save and close the drawing file, and reopen it, then there are no entries in the BOM. Only happens certain of my older drawings though? Really odd (and annoying)
     
  4. DavidJ

    DavidJ Alibre Super User Staff Member

    What do you see if you open the actual BoM file?
     
  5. Hunter

    Hunter Senior Member

    I see the entries, that's the weird thing. I've tried changing the font and reprojecting, that also doesn't make a difference.

    I made a new drawing now, with new assembly, and having the same issue.
    It happens with custom and default BOMs
     
  6. DavidJ

    DavidJ Alibre Super User Staff Member

    Suggest that you send issue to support (with the files).
     
  7. Hunter

    Hunter Senior Member

    OK, will do
     
  8. Hunter

    Hunter Senior Member

    Did a bit more research, the BOM gets unlinked for some or other reason. I suspect it has to do with custom properties in the part/assy files. I'll dig a bit deeper.
     
  9. Hunter

    Hunter Senior Member

    So I managed to fix it, but I cannot remember what I did exactly. I packaged one of the offending drawings and noticed that the BOM didn't get packaged with it. I then recreated the BOM in the package folder. Then the drawing and BOM updated correctly. I then copied the 'package folder' drawing to my previous location, along with the GLP file and BOM. Had relink the files to the drawing in the old location, but now it works. All my other drawings too. No idea, I obviously did something wrong with my copying of files. Seems it is somehow related to the GLP file, but not sure. That's my best guess. Anyhow, sorted now.
     
  10. DavidJ

    DavidJ Alibre Super User Staff Member

    Do you really mean copying files? that would mess up linkages.
     
  11. Hunter

    Hunter Senior Member

    Yes sir, I like to live on the edge! :rolleyes:

    No, but seriously, again it's habits learnt from other CAD systems. I now know to use Save As or Package, but initially I didn't know nor cared about that. I've been using 3D CAD for about 23+ years, they all work similarly, but Alibre is the odd one out when it comes to established or known workflows. Not saying it's a bad thing, just not what I'm used to.
     
  12. danwilley

    danwilley Member

    I experience this "empty BOM table" problem from time to time too. I did again today. The problem is frustrating because its seems random across the many assembly drawings I have . Now I have learned by habbit that if I go into an (old) drawing to make a change to a sheet, I always check the sheet that has the BOM to make sure it is intact. Most of the time it is intact but ocassionally it is not (it is empty). This happened on V21 and I just experienced it again today on V22. I have "Alibre Expert". I would rather not have to worry about disappearing BOMs because it is a waste of time.

    This is my sequence of events. I will go back into a drawing with multiple sheets. One of the sheets has the BOM, typically on a sheet to itself, and the BOM table is there but has no text...no column labels or other entries. The table is the correct size (column and row count), only empty. When I edit that BOM table (by selecting it on the sheet, editing it from the sheet), the BOM editor opens and the BOM in the editor is intact with all changes I may have made (re-ordering, font, etc). The BOM on the sheet is just empty. I delete the BOM on that sheet, re-link the BOM for the drawing, save, recreate the BOM on that same sheet. All looks good. I save and exit that drawing. I reopen the drawing and sometimes the BOM is re-populated. Most recently (just today), the BOM would be (constantly) empty again and again when I (imediately) reopened the drawing. I tried restarting Alibre to no avail. The part call-outs on other sheets within the drawing however stay intact most of the time. Today I lost no part call-outs.

    So I tried the following today (new for me) that seems to have fixed this instance of the problem. I deleted the BOM from the dedicated sheet... and created a new sheet, then added the BOM to that new sheet, saved. That seems to have fix this instance of the disappearing BOM problem for this drawing. So that original (BOM) sheet within the drawing must have been corrupted some how. To clean/finish up, I deleted the (corrupted) sheet, saved, reopened the drawing and the BOM is now intact on the new sheet.

    Note that sometimes just re-linking the BOM to the drawing fixes the problem (it seems). Today just re-linking did not help. Recreating the sheet did. Recreating a sheet is easy when the only thing on the sheet is the BOM. But, I have other drawings that have the BOM on a sheet along with associated dimensioned part diagrams, etc. It would be yet another level of frustration to have to create a new sheet with dimensioned parts, just to fix a broken BOM table.

    BTW, the assembly drawing I am working with today is an upper level assembly that contains lower level assemblies and parts. The drawing contains 11 sheets.

    Another bit of information that might be helpful. I installed V22 which now has "Textured Threads". I went back into a large project I am working on and added textured threads to all parts, assemblies and their related drawings. I processed the parts first, followed by the assemblies... bottom, up. I changed a part first (then save), followed by its drawing (then save). I had this BOM problem today with one high level assembly in this project.

    BTW..."Textured Threads" (V22) is really nice looking!

    Dan
     
  13. Ralf

    Ralf Alibre Super User

    Hi Dan,

    I have a short question, where do you save your Alibre files?
     
  14. Hunter

    Hunter Senior Member

    @Dan, I experienced exactly what you described above. I'll try your method of recreating the sheet and BOM if this empty BOM thing happens to me again.
     
  15. danwilley

    danwilley Member

    Hi Ralf,
    Windows and Alibre are installed on a local 120GB SSD drive... my "C" drive.
    All of my Alibre project files are saved on a local 2TB HDD (mechanical) drive... my "D" drive.

    Hi Hunter... Please post back on this thread if replacing the sheet fixes your problem. I have a feeling that the BOM sheet is being contaminated either by a memory management bug (as hinted by other threads, memory clean-up/mamanement) or some referential integrity problem when updating lower level parts/assemblies related to higher level assemblies. btw... I only have 8G of memory but Windows seems to manage it pretty well (not a lot of swapping) for this larger Alibre assembly when the assembly is being loaded and manipulated (by Alibre). I generally try to shut down superfalious applications when I am using Alibre. That said, I have had this BOM problem with smaller assemblies too.

    Dan
     

Share This Page