1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AddPolygon seems to divide x,y location values by 10 . . .?

Discussion in 'Alibre Script' started by R-man, Aug 2, 2020.

  1. R-man

    R-man Senior Member

    I've tried this with default units, and with units set to millimetres, with the same result. Anyone have any ideas?

    Code:
    P = Part('MyPart')
    
    sk1 = P.AddSketch( 'sk1', P.GetPlane('XY-Plane') )
    
    sk1.AddCircle(  10.0, 10.0, 5.0, False )     # add circle
    sk1.AddPolygon( 10.0, 10.0, 5.0, 6, False )  # add polygon in same place with same size
    
    # result: polygon is located at (1.0 ,1.0) instead of (10.0, 10.0) !!??
     
  2. idslk

    idslk Alibre Super User

    in this case i would assume it is a conversion failure in AlibreScript.
    It seems that the other features do not have this issue. If you use inches for unit, it also scales...
    It might be grounded in the circumstance, that Alibre internally uses cm...
    upload_2020-8-3_16-28-5.png
    Regards
    Stefan
     

Share This Page