1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2019 SP2 is available - manual installation

Discussion in 'General Discussion' started by Max, Dec 3, 2019 at 12:18 PM.

  1. Max

    Max Administrator Staff Member

    Hello everyone,

    2019 SP2 is available now but we're seeing a very bizarre issue with the autoupdater that will require some figuring out.

    In the meantime, you can download it from here: https://www.alibre.com/2019sp2/

    The most important element of this release is the ability to toggle between the new and old Print/PDF Publish pipelines. This is accessed through the newly resurrected System Options > Drawings > PDF dialog. This ability will allow users experiencing a range of issues related to 2D PDF publishing to use the previously well established method to obtain more consistent results, especially if publishing in languages with special characters.

    There are 2 options here:
    • Active PDF Writer - displays a list of all 3rd party PDF writers you have installed
    • Built-in PDF Writer - uses the HOOPS engine introduced in 2019
    What you select here controls Print, Print Preview, and Publish PDF behavior. As the older pipeline (3rd party PDF driver selected, Built-in disabled) produces more consistent results across a very wide range of use cases and languages, the older pipeline is now the default.
     
    Last edited: Dec 3, 2019 at 1:07 PM
    Eddy So likes this.
  2. JamesMC

    JamesMC Member

    That explains the weirdness...
    I got an update message yesterday, which disappeared after about 10 seconds, and the manual update didn't find anything.

    Anyway, the new pdf thing works better for me, didn't make any weird symbols on the drawing I tried it on.
    One thing, is it possible to add print all sheets and select sheets options to it?
    Its quite cumbersome having to append every sheet to the existing pdf for a 10 page drawing...
    Or have I missed an option somewhere?
     
  3. Max

    Max Administrator Staff Member

    Hi James, for multi-sheet please File > Print and choose the desired PDF driver as your printer. This gives you all the options for pagination etc. We have plans to add this stuff into the Publish to PDF at some point, but for now you can easily do it from the Print dialog.

    The autoupdate weirdness that we are seeing relates to an issue that appears at random on some machines whereby the installation will not finish and must be killed via task manager. We cannot yet explain this and have never seen it before. As such, we made the update live to do some quick testing and rapidly pulled it after verifying the issue remained.
     
    Last edited: Dec 3, 2019 at 2:11 PM
    JamesMC likes this.
  4. JamesMC

    JamesMC Member

    Roger, thats how I've been doing it with PDFill, will continue doing that.

    Cheers!
     
  5. DBC

    DBC Senior Member

    Hi Max, I am curious to know if a person who purchased AD 2019 but did not purchase maintenance can still get these fixes or does one already have to be paying maintenance to get them? I am just thinking that something like this should have been reliable in the first place since it is not a new feature and should be available to all. What's the word on this?
     
  6. Max

    Max Administrator Staff Member

    We agree. For this reason if you had access to 2019.0 you will get this without needing to be on maintenance. So if you have or could have 2019 at all you will get this update too.
     
  7. DBC

    DBC Senior Member

    Great. Thanks Max.
     
  8. jcdammeyer

    jcdammeyer Senior Member

    Will this continue to make the PDF's that are 3D. So a user can click on the parametric image and rotate/zoom? This is one of the best features of Alibre.
     
    anson likes this.
  9. DavidJ

    DavidJ Alibre Super User Staff Member

    The 3D PDF functionality remains.
     
    anson likes this.
  10. slipstick

    slipstick Member

    My install is hanging. It sits at this point for hours. I made sure my firewall wasn't blocking it, and I'm attempting to use Admin mode to run it. I am running Windows 10 Home version 1809 OS build 18363.476. It's a 64 bit installation. There aren't any pop-up windows behind this one.

    Any ideas?

    upload_2019-12-4_5-15-12.png
     
  11. DavidJ

    DavidJ Alibre Super User Staff Member

    Slipstick - was that from Auto update, or from downloading and running the installer manually?
     
  12. Max

    Max Administrator Staff Member

    This is the issue we were seeing with autoupdate on some machines. Haven't seen it yet if not using auto update, unless you perhaps ran the installer while Alibre Design was running.

    Do a full uninstall first, then install the sp2 fresh.
     
    slipstick likes this.
  13. sz0k30

    sz0k30 Senior Member

    I have had this same issue every time I have tried top update for a long time. I'm pretty sure I even posted about this problem. Then it tells me I have to do as "administrator" when in fact I am & have always been the only user and administrator on my computer. I wind up having to always do an uninstall & then install.
     
  14. slipstick

    slipstick Member


    That worked. I did do the manual download. Thanks!
     
  15. Serenity

    Serenity Alibre Support Staff Member

    Would you mind telling us what Antivirus software you have installed? We have a theory that there may be some miscommunication between certain AV software and the auto-updater, but it still needs to be confirmed with further testing.
     
  16. slipstick

    slipstick Member

    I'm using BitDefender Total Security.
     
  17. sz0k30

    sz0k30 Senior Member

    I don't know the dates of which AV I used when, but I have used ESET and Norton, Now I have Trend Micro.
     
  18. Max

    Max Administrator Staff Member

    Turns out BitDefender, which is what we use internally, flags this particular build as a false positive. For that reason we had a very high internal failure rate during autoupdate testing, which for some reason is flagged whereas a normal uninstall/reinstall is not.

    Since nothing can be done about it, and since most of the universe doesn't use our particular AV solution, we've made the autoupdate available again.
     
    swertel likes this.
  19. NateLiqGrav

    NateLiqGrav Alibre Super User

    It could be the inclusion of a dynamic scripting language that triggers the flag. AutoHotkey has had to deal with antivirus false flags for years.
     
  20. swertel

    swertel Alibre Super User

    Mine hung on the final step as well. I had to kill the process. Alibre runs and everything seems to be fine.
     

Share This Page