1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2019 Opacity and planes

Discussion in 'General Discussion' started by Larry, Aug 9, 2019.

  1. Larry

    Larry Member

    This observed in v2019, both build 20050 and ...51. Can't always reproduce this easily - under certain viewing angles of an assembly, sections of an object (with an opacity setting of less than 100%) will disappear.

    The included screenshot shows one case of this - the longer rectangular cover shell (with the two BNC connectors) has an opacity set to 80%. Between the XY plane and XZ plane this shell disappears exposing the circuit board inside. Anyone seen something similar - some setting I'm missing ?


    2019_20051_1.jpg

    Thanks.
     
  2. Max

    Max Administrator Staff Member

    This is due probably to a combination of things:

    1) You are using shaded planes - you can disable shaded planes if you want and (System Options > Design Viewing > Shade Reference Planes)
    2) A relatively low value for Transparency Layers (View Tab > Optimize Performance)

    Basically the transparency layers setting determines how many consecutively transparent things can be rendered at any pixel. Setting high gives you several layers of depth for transparent objects, and setting it low gives you very little. Shaded planes consume up to 2 of these levels, depending on view orientation.

    So my suggestion is 1) Turn of shaded planes 2) bump up your Transparency Layers option by a notch or two and you should see the issue go away.

    Thanks!
     
  3. Larry

    Larry Member

    Max, much appreciated, works here as you described. Interesting interactions between Shaded Planes and Transparency Layers - always something new to learn. Thanks.
     

Share This Page