1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

20072 going off the rails again

Discussion in 'Using Alibre Design' started by JST, Jan 11, 2020.

  1. JST

    JST Alibre Super User

    So, working on a client project, and 20072 is acting very wonky.

    First, I am trying to do a plain ordinary sweep boss. It's for a u-bolt, and so I put two circles on the first plane, and click the sketch icon to close that...... hey what's this? The sketch won't go away, it stays as a ghost image, even though sketch 1 is shown and the icon indicates it's closed.

    I close Alibre and re-open.... same thing. Finally it seems that goes away, I put the path on the normal plane, and the bolt is swept apparently OK, no errors. But maybe not......

    I go to put the bolts in an assembly, and when I try to get them lined up and tangent aligned so they stay put in position..... tangent outside gives an error of overconstraint. What the ....... ? I try tangent inside, same thing. This seems to be persistent... BUT....

    Then I close and re-open the assembly. Hey, it did the tangent inside when it opened! OK, I edit it to be tangent outside, which is what I want, and again it refuses with an overconstraint!

    Finally I make it visually OK by hand, and move on. But what is going on?

    This is pretty inconsistent, and weird.

    That seems to be an ongoing issue with 20072.

    Still got the memory leak. Have run out of memory more than once even with 16 gB.

    Got odd problems that pop up and seem to have no cause, such as this constraint issue..

    As far as I can see, there is nothing about this machine that should be a problem, it seems to be at least "good enough" and probably better than needed.

    So, what is going on?
     
  2. JST

    JST Alibre Super User

    Next oddity..... same part that I have had no issues with zooming in on, NOW when I zoom to where I can select the end of it, IT DISAPPEARS.

    Yeah, yeah, blah, blah, check the facets and all that jazz. BUT WHY? This exact part file has been fine, and all of a sudden it is a problem... WHY?

    Then also, I DID zoom to where it SHOULD have been selected on the end face, but it WAS NOT. That's goofy too. (and it is why I zoomed more, which I have done before as well.)

    I have ONE PART in an assembly workspace. It is a piece of round bar 2.5" diameter and 10 ft long. Not your most complex part. And it has been working fine in a couple of other assemblies. Same base part file.

    Again, this machine should be OK.... it got Max's blessing as a good choice, so that should not be the issue, is must be an alibre thing.

    And now, just to make the whole thing even odder..... I never closed the part, just opened a new windowe to come and write this.

    But, when I went back to the model, guess what? It decided that it could zoom in as far as I want..... AND it will select just fine.

    And before I get asked to send in the file with a report, what the heck will that do? Everything is working again for THIS particular issue. All I did was basically switch windows by going and selecting the forum through the "explore" tab of Alibre, posted this post, went back to Alibre, and that seems to have somehow shocked the system into working again.
     
    Last edited: Jan 12, 2020
  3. simonb65

    simonb65 Alibre Super User

    It will log the issue (repeatable or not) with the dev team. If it's not logged and on their radar, it will not get the attention it deserves. It maybe that your not the only one (I suspect a very small percentage of users are on this forum!). Log it, let Alibre decide how to use and investigate the report!
     
  4. DavidJ

    DavidJ Alibre Super User Staff Member

    It is possible that your log files may have picked something up - include them with any report.

    If the problem occurs again, try taking screenshots to show the issue - then at least you'll have something to show if the issue 'fixes itself'.

    Check for graphics card driver updates, check if using 'Legacy Display' gives a better result (though since it requires a re-start, this may not be definitive).

    One thing I don't follow from your initial post - why would you have 2 circles in your profile sketch for a U bolt sweep?
     
  5. oldfox

    oldfox Alibre Super User

    I don't get it either.

    The "New Part (1)" is just my playing around with the originally described problem. (as I underestand it) It works for me. Zoom works just fine. Try playing around with different sweep combinations and see if anyone can break it. I can't.

    The sweep "Path Object" is Sketch<2>.
     

    Attached Files:

  6. oldfox

    oldfox Alibre Super User

    One thing that is evident with "hoops" is the delay between clicking something and that something happening. Once I got used to it I just
    moved on and now don't worry about it. If it's slow, it's slow. That's another issue to be worked on later. If JST is working real fast, that
    may be an issue. Another "what's this" is when I do a "Precise Placement" I can't select the same part after I close the tool.
    Well, I discovered that sometimes if I just waited a bit, (seconds, not minutes) it would again be selectable. Precise Placement will make
    the toolbar "Save" icon active. I can always Save and then the select process is again normal. This could be an issue that is being
    interpreted by the user as "It's broken". I would have to say "Not broken, just slow." IMHO. Something for Support if nothing else.
     
  7. DavidJ

    DavidJ Alibre Super User Staff Member

  8. oldfox

    oldfox Alibre Super User

    Hi David,

    Thanks for the lead.

    I read through that article and it hits on more than one thing I have noticed. I'm going to go through it again step by step and see what
    improvements show up. I do, in fact, have a "low end" computer. It is a self built tower, 2009 vintage.

    It uses...
    ASUS M2V-AM motherboard with 6GB of ram.
    AMD Athlon 64 X2 Dual Core Processor 6000+.
    NVIDIA GeForce 8400GS display adapter with 1GB memory.
    Monitor is a BENQ GL2460.
    Logitech M510 Mouse.

    Since I'm on a fixed income, expenditures are right up there on the priority list. :(
    I'm surprised that I get the level of performance that I do.

    Since I'm retired and don't have to answer to a deadline anymore, I'll take "slow" over $$$. So long as I can just get the job done.

    oh, btw...

    That article answered one question I've had since the release of Hoops. In the system properties under Display, the note after the
    display mode, "Restart Required", always confused me. Does that mean "Relaunch" Alibre, as pointed out in the article? Or "Restart"
    as in "Warm boot" of the computer. I know that a lot of things get loaded on bootup and not just by relaunching a program so I
    have been doing a computer "Restart". Here again, I have the time.:D I'll quit doing that from now on when I change display mode.

    Thanks again.
     
  9. JST

    JST Alibre Super User

    Two circles simply because I was silly, and left an extra one there... because I decided to move the start point, forgot to delete the original circle. Never thought about it, because I somehow conflated it with a loft I did previously, which would of course have start and end forms..

    That odd "error" may have caused follow-up problems, sure. I get that. But the program never so much as hiccuped about it, it just showed the ghost image, OF BOTH CIRCLES. But then I was not thinking about the extra, or I would have gone back and got rid of it.

    But, that brings up another point!

    The program did not do that correctly....

    1) Why did it NOT sweep BOTH circles, when both were on sketch 1, and sketch 1 was the thing to be swept? That would have alerted me right away to the problem.

    2) I think that two closed forms may be a prohibited condition for the sweep, and if so, why did the program never give an error message about that? it went ahead and did it just as if everything was good.

    3) If they were treated as one form, and were swept as one part, they would have intersected, why did this not produce an error message as is usual? It is not good when the program will allow one to "booby trap" a part that will then cause problems later.

    I assume the "possibly marginal graphics" is not about me, since I was told by Max that what I have is plenty good.
     
    Last edited: Jan 12, 2020
  10. JST

    JST Alibre Super User

    Another oddity:

    Replaced parts in an assembly, and one of the new parts would not move. I discovered that it was "anchored" after the replace part operation. None of the parts were anchored before that, they are angled legs of a radio tower, with tabs for crossmembers, and had to be set at that angle by constraints, no reason and no need to anchor the parts, they are fully constrained.

    Why did the program anchor a part during the "replace" action? I replaced all 3 parts (assemblies, actually) in one operation.

    The one part was anchored, but not constrained. The others were just not constrained. But I had specifically set up to NOT lose constraints, unchecking the "remove constraints" checkbox. The components were the same components, with a minor position change of parts not used in constraining them. All geometry should have been the same with no name changes.

    I have noticed this before.
     
  11. DavidJ

    DavidJ Alibre Super User Staff Member

    YES - that is why I started that post with 'Oldfox'
     
  12. JST

    JST Alibre Super User

    Tx, assumed that, just checking.
     
  13. HaroldL

    HaroldL Alibre Super User

    I've always interpreted that to mean "Restart Alibre Required" and it seems to have worked for me. If I am updating or installing software and I see a message stating "Restart Required" that's when I do a computer restart since some files need multiple steps for a complete install.

    If only restarting Alibre is necessary, maybe to avoid any confusion the word "Alibre" should be inserted in the "Restart Required" text string.
     
  14. oldfox

    oldfox Alibre Super User

    That would work. Or just not using the word "Restart" and use maybe "Relaunch" or "Reload".
     
  15. JST

    JST Alibre Super User

    So, we are having another fit of "no, you cannot select anything about this part, and if you get too close, we'll make it disappear". Again a plain solid round form. No rhyme nor reason.

    Brought the part in, aligned it with the Y axis, and was going to constrain one end to the Z-X plane, which is when it went south..

    Went off and saved and closed the file, opened again, all good.

    REALLY? This has no business happening.
     
  16. JST

    JST Alibre Super User

    These parts are tangent.jpg And another one. Not sure about this one, but I am certain I have done this before.

    The piece of SR that is the tower leg, gets a piece of half pipe clamped to it (around it) as reinforcement. So, as I usually do, I simply assemble the parts, so that all the pieces get counted up. I do not in this case need to reproduce the tower taper, since that does not affect the fits.

    I am pretty sure that in the past I have used the "tangent" constraint to fit the half pipe over the solid round. The half pipe inside diameter is slightly over the SR OD, so it would be line contact.

    But, I select the inside of the pipe, and th OD of the SR, and the tangent proceeds (tangent inside, the outside did not work at all)..... but the parts do not move. No errors, but the piece of half pipe act as if it is tangent to a part that is over where it is, it did not move to be tangent.

    I saw a similar deal before, only there, the u-bolt gave an error when I tried to place it tangent to the outside of an SR piece. But the time before, it had worked , on another piece. In fact, it worked once on THAT piece, only there was another problem that forced me to undo that.

    As far as I know, the tangent used in this way should (and has) end up with the half pipe in line contact with the SR, and all should be well. But with this version and these parts, (same as other from the past) it does not.

    I want the fit-up because I need to judge the bolt stick-out for nut and washers. And I want to illustrate the setup, with callouts. Can't use align, as that leaves visible gaps.

    UPDATE:

    So, I do a different assembly, and, right away, it works fine, tangent is perfect. Yet, before, with the same parts, it absolutely refused to work right.

    REALLY?

    Another UPDATE:

    Spoke WAY too soon.

    It SEEMED to work and I think it did. The half pipe stayed aligned but would rotaqte around.

    But then I wanted the half pipe to be oriented a certain way. So, I used an orient on the cut surface of the half pipe, to orient to another feature.

    KABOOM...... Now the half pipe is totally unconstrained....... moves anywhere. So I undid the orient, thinking it would snap back in position, or could be moved there.

    Nuh-Uh..... it stayed in the new location (and angle) that it moved to, AND ROTATED AROUND AN IMAGINARY AXIS THERE.

    Folks, you just can't make this stuff up...........

    These parts are tangent....... sez Alibre.
     
    Last edited: Jan 13, 2020
  17. NateLiqGrav

    NateLiqGrav Alibre Super User

    Fyi I've had unexplained problems with Alibre lately too. I assumed it was mostly due to the odd things I'm doing with Alibre Script but I think it's a symptom of something deeper in the Alibre program.

    The following problems I find randomly with scripts:

    Parts in an assembly with a single extrusion without any ability to select them (in 3d) unless I edit the part from the design explorer and regen. I can usually select other parts in the same assembly.

    Not being able to add parts to an assembly because the program can't find the assembly it just added a different part to.
    System.Exception: Unable to add new part to assembly. Make sure the assembly has been opened for editing. Failed to locate inclusion node

    I have to restart the PC (or end process tree of Alibre seems to work) to get scripts to function again - until some random thing causes problems again.
     
  18. JST

    JST Alibre Super User

    Thank you for that...... now I do not have to run a 4 hour memory test to make sure stuff is not getting corrupted here.....
     
  19. DavidJ

    DavidJ Alibre Super User Staff Member

    If as you say, the solution would be line contact, there would be many different solutions possible. You'd have to add extra constraints to restrict the possible solutions so that the 3d constraint manager can work out what to do.
     
  20. JST

    JST Alibre Super User

    None of those other solutions would include being out to the side and at an angle to the SR, unless I am visualizing this way wrong. But that is where it was. And it was tangent-constrained, because it would rotate around it's axis, which was not a feature of any other constraint applied at the time.
     

Share This Page